Main Site Documentation

Getting build environment set up


#1

Hi,

I’m pretty good at the Arduino and am trying to get working on a platform with more SRAM for my current project: http://goo.gl/GezauP

I downloaded and installed MSVC 2010 C#, and .NET Micro Framework SDK 4.2 (QFE2) and everything on the instructions here ( http://goo.gl/6joVK1 ) for MSVC2010. That didn’t really work. I had to install the .NET package and GHI twice. And still items aren’t showing up in menus the way the tutorial ( http://goo.gl/3uzCLo ) goes.

Perhaps the tutorials are written for experienced MSVC or .NET developers?

Currently removing it all and going to try again with the 2012 tools… Or is there a netduino tutorial I should follow that will apply to my new FEZ Cerbuino Bee that won’t skip “obvious things” someone new to .NET might miss?

Thanks,
Chris


#2

Hi thanks.

Yes, I did that because it was recommended… I’m watching the Visual Studio Express 2012 for Windows Desktop fancy loader thing working now. I’ll check back when it’s done and I can blink an LED. :slight_smile:


#3

Hmmm, still don’t have the “Note how there are some template for GHI NETMF boards but for this tutorial we will be using the emulator so we won’t use these templates just yet.” mentioned in the first project page.

So I look at the schematic and see LED1 is on PB2…

I did try the blink via “Visual C# -> Gadgeteer” and I chose the picture of the FEZ Cerbuino Bee and when I ran F5 it complained:

[quote]Assembly: GHIElectronics.Gadgeteer.FEZCerbuinoBee (4.2.100.0) needs assembly ‘Gadgeteer’ (2.42.0.0)

Assembly: GHIElectronics.Gadgeteer.FEZCerbuinoBee (4.2.100.0) needs assembly ‘GHI.OSHW.Hardware’ (4.2.6.0)

Error: a3000000[/quote]

Those references are added as I put them as “using” in the code like the other examples…

So I go try blink via “Visual C# -> Micro Framework -> Console Application” like in the getting started example. When trying to add References, none of the GHI ones appear. If I go to the Recent tab, the ones I tried in the 1st attempt show up. Hmmmm. OK. So I add those.

Now hitting F5 doesn’t take the time to connect and reboot and debug blah blah, just an immediate error: “CLR_E_ENTRY_NOT_FOUND”

Hmph…


#4

Remove the reference to EMX.
EMX if for premium boards like spider …


#5

Hi Jay Jay, tried that, too, after. And then confirmed it again just now. Reinstalling MSVC# 2010 so I’ll try all that again.

Does anyone who develops the support docs ever go back and actually try to follow them on a new system? Or better still, watch an Ubuntu guy try to? I only have this Windlws 7 x64 box because CAD, CS6, and 3D printing require it.

New screenshot added…


#6

I just install MSVC 2010 and for grins, ran the Netduino installer. Their template options showed up on the new project screen.

Something is definitely wrong or missing with GHI Electronics build environment.


#7

Can you please show application tab from the project window and output window.


#8

Will do… currently trying to reinstall 2010 from scratch…


#9

If you don’t have install full .Net 3.5 SP1 as well.


#10

I’ve recently built the full VS2012 and netmf without issue. Since you mention some legacy devices, make sure you’re installing the GHI 4.1 SDK, since that’s where you get the references for Domino.


#11

My sole GHI device is the Cerbuino Bee http://goo.gl/tCqHfL … I’m pretty much hating what MSVC2012 does, so sticking with 2010 and .NET 4.2 is an easy choice for me. GHI 4.1… ok, got it. I’ll load that up instead of the GHI SDK 4.2 I brought home from work.

BTW, the desktop at work is thoroughly upset; I’ll probably have to reinstall windows. :stuck_out_tongue: So I’m at home destroying my personal laptop’s install now. I did a screenshot of the microsoft products before I started.

Had I thought ahead, I probably would have bought a new computer to screw up with the MS VC stuff. :stuck_out_tongue: It’s worth the $300 not to have to release all the licenses on the CAD computer to have to reinstall windows. So… fingers crossed there. At least it was “just” the CAD workstation and not the other Windows computer we have: “shipping”. When it breaks, our business stops making money.


#12

OK, so I read up more and I believe that the Cerbuino isn’t a “legacy device” so I went ahead with GHI 4.2 install.

And I got an exception, no less. Seriously? What kind of mickey mouse **** is going on here? Do you folks save up the biggest f-ups for the linux people to keep us hating Microsoft for like the next 20 years?

:frowning:

This laptop is pretty virginal, too. All lightweight stuff installed, so shouldn’t be corrupted with other .NET this or MSVC redistributable that.

** reaching for the whiskey, it’s gonna be one of THOSE nights **


#13

BTW, for anyone following this, the download is 237,054 KB and when run, window opens copying a ton of files then closes. Maybe windows will ask if it installed correctly. And then it doesn’t show up in “Programs and Features”. I question the advice to install .Net 3.5 SP1. Once these files are in, there appears no way to get them out.

Good times. I’m rebooting my computer now. Bye.


#14

OK, now we’re walking through my adventure on this fresh computer…

I go File -> New Project … and there are none of the GHI or FEZ items in the list with “Console”, etc. See screenshot. Same experience I got with the 2010, 2012, and 2010 reinstalls earlier today on my desktop workstation.

So, far am I… or am I not… insane, for expecting a different result from performing the same task so many times?

Crap, forgot the whiskey. Going to get before I repeat today’s attempt to make PB2/LED1 blink via MF as well as Gadgeteer…


#15

Is the attached screenshot what you are needing?

This time, the error is different:[quote]* ERROR!!! Firmware version does not match managed code version!!! *

  •                                                                 *
    
  •                                                                 *
    
  • Invalid native checksum: GHI.OSHW.Hardware 0x09E0F047!=0xF0D4135D *

Resolving.

The debugging target runtime is loading the application assemblies and starting execution.
Ready.

Cannot find any entrypoint!

Done.[/quote]

Annnnd… searching on that invalid checksum leads to updating firmware? ( http://goo.gl/cWPYLv ) So a product I receive from GHI Electronics today requires firmware update? If you guys say so, I’ll do it. I’m just not expecting something this new to need this much work. If “yeah, that’s normal” say so and I’ll blindly accept the advice and go forth.

Thanks,
Chris


#16

Here’s the “Blink” project… remember, I’ve got a FEZ Cerbuino Bee … and the schematic says PB2 is LED1. Even the chipKIT’s blink was easier than this… and I made it do … — …


#17

… just tried it again using Gadgeteer instead of MF and got the same results as I did at work on page 1 with Gadgeteer:

Assembly: GHIElectronics.Gadgeteer.FEZCerbuinoBee (4.2.100.0) needs assembly 'Gadgeteer' (2.42.0.0) 
Assembly: GHIElectronics.Gadgeteer.FEZCerbuinoBee (4.2.100.0) needs assembly 'GHI.OSHW.Hardware' (4.2.6.0)

Error: a3000000

#18

ok, sorry about that I confused your thread with another !

Yes, if you’re not doing dev on USBizi devices (Panda, Domino, ChipworkX etc) then you won’t need the GHI 4.1 framework as well.

Now let me say about the “first app” page https://www.ghielectronics.com/docs/21/first-netmf-project that IS based on the 4.1 SDK timeframe so you can safely ignore the fact that you don’t get the things outlined there - what your image shows is perfect.

I do have one new pointer for you - you always need to do the firmware check when you install a new SDK - so please whatever you do make sure you deploy the firmware :slight_smile:


#19

Whoops - sat on that post for bit and you’ve replied - that error just confirms, you now need to update the firmware on your device, sorry - one more small hurdle


#20

[quote=“Brett”]I do have one new pointer for you - you always need to do the firmware check when you install a new SDK - so please whatever you do make sure you deploy the firmware :slight_smile:
[/quote]

I got the Cerbuino today. Er yesterday. There was no SDK to get a new version of. The support docs mention .NET MF 4.2 RTM (QFE2), which was released Aug 14, 2012, or about a year and 3 days before my board shipped to me.

Support docs also mention NETMF and Gadgeteer Package 2013 R2, which is shown as released on Aug 26, 2013. THAT is about the same time my board probably shipped. MAYBE GHI could have held back known defective and needing updating products? That’s what I do with my company… I choose to NOT ship out known problematic goods.

Today’s loss of productivity isn’t a “small hurdle”. It is the intentional choice by GHI Electronics to ship me a product that would not work.

I can’t believe I had to check my email one last time on my phone before going to sleep… Now I don’t get to go to sleep because how pissed off I am at GHI. Someone better prepare them for the absolutely irate, tired, and sleepless guy that’s going to be calling them in about 9 hours from now. After I’ve had enough Red Bull to form coherent thoughts.

GHI equals fail. I read on the internets about the “great customer service”. Nope, sorry, I’m going to go find all of those happy and cheerful posts on Sparkfun and other sites and be sure to let folks know that the actual first step in opening up the product is to update the firmware, which apparently involves some voodoo with shorting two contacts with a wire. Why? Because I juuuust got the product from GHI directly TODAY, who apparently, think it’s OK to send out things which they could easily fix but instead make fun games for people trying to get work done that impacts another business.

When I get to work, I’m going to pile up the boards I have purchased which do not need “firmware updates” in order to blink a freaking LED on the board itself. And I’ll put the lone GHI board next to that pile. And I’m going to take a picture.

I’m not joking. Someone here who cares needs to talk to someone at GHI who cares and figure this out. And I thought chipKIT was lame for not being able to do I2C out-of-the-box?

Why… why did I click on the email when I was done with Candy Crush? :frowning: