Gadgeteer Mainboard in tool box is not usable

I am new to gadgeteer. After getting my board updated, I started to follow the starter kit guide for FEZ Spider.
But the GHI Mainboards in the toolbox became unusable after I created the new Gadgeteer Application from VC#2010.
Can anybody help? Am I missing something in the setup? The boards are in there when I used showall option for toolbox.
But they are greyed out. Thanks!

Hi Raabs, sorry to hear you’ve not got this working. I think we’ve seen this at least once before, and I am taking a big stab here, the install order was the problem? Do you think that might be possible? I’m going to hit search and I might be back with an update. seems the closest I can find; removing and reinstalling the SDKs in the order shown helped. That’s my suggestion.

Thanks for the reply. The order is what I suspected. So I uninstalled everything and tried to follow the order specified in the doc.
I still had problem witha C# express. I then tried I a different machine, where it has Visual Studio.
I got a better result - that .Net Gadgeteer Application (NETMF 4.2) works, I can add the main board and other modules.
But the .Net Gadgeteer Application (NETMF 4.1) still doesn’t work.
Is that expected? It only works with 4.2?
Does that mean I have to update the firmware to 4.2 also?
But when I read the 4.1 to 4.2 update document it says if you want WiFi, one should stay with 4.1.
So I am little confused about what is available and what is supported?
Sorry for these silly questions, but I am very new to this.

There’s no silly questions so don’t worry too much. You’ve just arrived here at a time when there’s some churn in versions so there’s a bit more to think about.

There are TWO packages you need to install, from the support/install page, to get Netmf 4.1 working (* I think*). If you didn’t install the GHI 4.1 SDK, marked OPTIONAL, then perhaps install that. But can you elaborate on “still doesn’t work” means when you create a new 4.1 project?

With regard to Wifi, it’s true that the earlier 4.2 SDK betas didn’t include WiFi but that’s no longer the case - see for the info on the release candidate. And yes, when you are working, you need to install the correct firmware for the version of project you are creating - so if you’re creating 4.1 projects then you need 4.1 firmware loaded, create a new 4.2 project and you need 4.2 firmware.

Thanks! Since I had trouble updating the firmware, I was trying to avoid have to upgrade to 4.2.
I will try to restart from fresh tonight and report back. Thanks a lot for you q quick reply.

4.2 will be worth it once you can.; I’d suggest that given the challenges you had, I’d also think that waiting for a full SDK release before moving forward made sense - but since you’re kind of in no-mans-land right now, if you want to use the device you have to forge ahead I think.

Yes. It worked! I unintsalled everything and followed the installation process step by step. Had to manually install the driver when updating the firmware.
Other than said. It worked flawlessly. Now on to the fun to create our project! Thank you so much for your help.

no worries, glad you are sorted. Remember to tick an answer so it disappears from the unanswered list