Main Site Documentation

G400D -> USB Basic Problem


#1

Hello!

It’s been awhile since I tried to connect to my G400D.
When I first connected the usb/debug port on the eval board, I was able to see that
the G400_Gadgeteer Device in the FEZ config program and I could Ping it.

So, then I tried to run my program under debug. It loaded and I could step into it but it bombed on a call to init the pwm. But after that, I can never even connect or ping the G400D.
And I don’t see it in the Win7 Device manager. (using Win7 32 bit OS).

From the FEZ Config program at the Connection menu, if I unplug the usb from my computer, then plug in, I can see the G400_Gadgeteer Device appear in the Device section but only briefly, then it disappears and in the bottom right corner there is printed Status: No device.

I’ve tried rebooting the pc, powering off the eval board, reseating the G400D in the eval board, and numerous things but cannot seem to get the usb connection back.

any suggestions? thanks!


#2

If you ask me then I would suggest you erase it all and start using TinyCLR :nerd_face:


#3

Try a different USB cable/port/length of cable. Try USB 3 vs USB 2. Reflash it with a basic program that just outputs debug messages in a loop, to verify that it’s not a hardware issue.


#4

erase it all? what exactly do you mean?
How can I erase it?
I can’t even see the device from FEZ Config.

thanks!


#5

Mr JS -> I already tried different ports, don’t have another cable.
Can’t reflash it with a basic program because I can’t even connect to it.


#6

Ok, I think I know what may have happened ->
When I first connected today, I could ping it and so it was connected.
But, because it had been a long time since I did this, I accidentally
loaded the wrong software from VStudio and tried to run
a program written for the Cobra on this G400. Maybe when it downloaded, it
screwed everything up.
But now would be happy if I could just get it to connect with the FEZ config, maybe the G400 is
toast now???


#7

Start by loading v2 loader

http://docs.ghielectronics.com/hardware/ucm/g400d.html


#8

Ok Gus, thanks for your help.