G400D NETMF4.3 - unformatted SD-storage device

Hello there

I continued my project to realize a sqlite database application using sd-card as source.
I am faced now with an other problem. I have some different SDHC with varying speed(class 1,1,4,10).
The netfm application detects at each card an unformated storage device.
The cards have been formatted in windows by system or by SD formatter. No matter…
During the mf-mounting I don’t use any extra parameters for speed.

what’s wrong?
according to which specification sd-cards for g400-d and NETFM must match?


Are the cards formatted in FAT/FAT32? Some are in exFAT or something by default.

FAT32 Format has been always used.

1)An other point of formatting is the block size. I have never read about block-size incompatibility.
2)There are some samples using mount(int speed). How can I find out if the optional speed parameter has to be used?
(once I tried to select a speed, this leads to an ghi.hardware.dll exception)

@ hweinfurterAAEj4i5 -

Try a small and simple application that just mount the SD. If the problem is still there, post that code to here then we can take a look.

I’ve used SD cards with the G400 with no issues at all. I’ve used both the legacy SPI and the newer MCI interfaces.

I don’t think the speed value is used. Just use mount();

@ Dat:
I found a very simple code posted by yourself. the code describes how to manually mount and check sd-card volumes.
mounting was successfully but the sd-card volumeinfo replied is always ‘unformated’

I tried to manually implement a ondevice format by [em]vol[/em].Format(“FAT”,0)… but this failed after a big time delay
FAT32 failed directly after calling “Format”

I’ve read in different postings, that an invalid mount speed leads to an exception during the mount operation in the hardware.dll.
So that’s clear for me.

Is there any case, where the sd-card volume is recogniced correct but accessed in invalid way so that netfm gives wrong feedback.
– recogniced in wrong way means, invalid hardware access through port pins…


Formatting with “FAT” means in my case:
2GB SD-Card formatted as FAT16

[quote]Can anybody tell me sd-card types which are successfully in use on G400D?
Please specify file format, class, speed, vendor, size of volume [/quote]

@ hweinfurterAAE
Because of somehow, I (Dat) modified this post and no way to undo it :)) Sorry hweinfurterAAE. I think I need some coffee.

@ hweinfurterAAEj4i5 -

[quote]Can anybody tell me sd-card types which are successfully in use on G400D?
Please specify file format, class, speed, vendor, size of volume [/quote]

No specific file format, class… just format by window and keep everything default except change to FAT32 even the size is under 2G

And post a picture that shows us how you connected the SD card to G400

I found new micro sd-card which is detected in a correct way.
I didn’t elaborate the difference in specification yet.
from a standard point of view no difference, FAT32…

thanks all

@ hweinfurterAAEj4i5 -
I had similar issue on G400 (didn’t properly detect some cards) and the issue was in the poor connection on breadboard.

@ EvoMotors - can you describe poor connection?
I found out that some valid cards be invalid in a bad hardware situation. the cabling seems to be correct.
The valid card has been detected as unformated inspite of being formated.