Main Site Documentation

G400 Update Problem


#1

[started new thread to keep announcement clean]
Installation of TinyBooter worked fine. When trying to update the firmware - fails.
Tried Pinging - OK
Tried getting version - takes forever … prints version and dies (see image).
Firmware update also takes forever and fails (see image 2)
Windows 7, 64bit
G400 shows: Build Date May 6 2013 15:12:21
waiting for debug commands …

Went back and tried to reinstall the original Beta firmware, which had worked fine. Same problem with the FEZ_Config_v011 Updater now. The only difference I can see is that the Updater I'm using is now FEZ_Config_v011. I don't have the original any more. Can you give me a download link to get the original/old FEZ_Config to try? Since the Bootloader update works fine (logs OK), it must - hopefully - be the v011.

#2

I am having the exact same problem with the only difference being that I am running Windows 8 x64.


#3

I also struggled with the same issue last night. Win8 x64. Sounds similar to https://www.ghielectronics.com/community/forum/topic?id=12210


#4

@ ransomhall, JREndean, and Lurch

I updated the developer page with the proper instructions. As with the link that ransomhall provided, it is explained that the initial shipped version of the G400 did not include TinyBooter which will make the firmware updating process impossible with the config tool if the version of the firmware is 4.2.0.0. It will be necessary to follow the TinyBooter Update Procedure to allow for the firmware to be installed correctly.

The following link id to the developer page for further details: http://www.ghielectronics.com/docs/112/g400


#5

Thanks!


#6

I found my mistake and adding it here in case anyone else had the same thought process. I had read “From this link: http://www.ghielectronics.com/downloads/beta/G400/ A newer TinyBooter or firmware will be zipped in a file reflecting the firmware number.”, so I automatically assume that “G400 Beta Programmer(4.2.0.0).zip” was the newer file and was the replacement for “G400 Beta Programmer.zip” but “G400 Beta Programmer.zip” is the file you want to download, unzip and use (ensure that it has G400_TinyBooter.tcl and G400_Tinybooter.bin).

Once I figured that out :slight_smile: then everything has worked as expected with no issue in updating TinyBooter or the firmware and deploying a test application.


#7

@ JREndean -

so I automatically assume that “G400 Beta Programmer(4.2.0.0).zip” was the newer file

That is exactly what I assumed and got me in trouble…


#8

Beta testers sure need a lot of coffee. :slight_smile:

Been trying to update my G400 board and after 5 BSOD’s I finally stumbled across this posting.

Now I have it updated with the correct TinyBooter and latest firmware.

The files still remain without proper names that would make it easier to know which version is the latest.


#9

Really? “Don’t use” in the filename not a hint ? :wink:

Admittedly, the last updates to names was about a week ago, and before that you needed to do maths that said 10.0 was less than 10.1 :wink:


#10

They didn’t have that when I downloaded them before. I had assumed I had the latest as it was 4.2 :slight_smile:


#11

I just found this post and it describes my exact problem.

Now when I put the G400 in bootloader mode the PC doesn’t recognize the device. In other words the virtual COM port doesn’t show up.

Any ideas? I really need to get it going as I have to have a replacement for the ChipworkX.

Thanks.


#12

@ rncox

Under the Program Files (x86)\Atmel\sam-ba_2.12\doc directory, there is an HTML file that is entitled usb_notice.html. It mentions that the old driver that may have been previously installed may not function correctly. Follow those instructions to see if they will work for you.