G400 Recover Loader

I think I did something wrong while updating my G400-D. I tried to update the firmware via FEZ-Config but now it just boots to the bootloader no matter if I set LDR0 and 1 low or high. It’s only visible as the COM-Port and not as USB-device. The only thing FEZ-Config tells me, is that the device is not responding… Is there a way to get it running again?

@ glx - Have you deployed the GHI Bootloader from https://www.ghielectronics.com/docs/336/g400-bootloader-installation? If so, it sounds like TinyBooter is not loaded or running. You can always go under the Advanced menu in FEZ Config, pick Loader Update, and select the G400.

1 Like

The loader-update via FEZ-Config didn’t work (it just told me that the device was not responding). With the Bootloader-Installer from your link it works now again :). Is it possible, that the loader was to old for the firmware I installed? I haven’t used the G400 for a while and I just wanted to update the firmware with the version from the newest SDK.

@ glx - This SDK contains the release of the bootloader for the G400. Going forward FEZ Config will be able to update TinyBooter and the firmware without needing to use samba and the updater scripts like before.