Main Site Documentation

G400 hardware error


#1

Hi, we have the G400-D Module Beta Test Kit
I could put in bootloader mode, and run programg400.bat com20 successfully.
I have installed gui libraries from May, 2013, and .netmf 4.3
I can ping it from MFDeploy.
However, “Show device info” function does not work, it takes a while and shows "object not set to an instance of an object"
Also in Visual studio I get “An error has occurred: please check your hardware” when trying to deploy (tried vs2010 and 2012)
Any ideas of what is happening?
By the way, do you have any code example to work with g400? I was used to Mainboard m = new FEZHydra() (something like that)… but can’t find anything to write: new G400()… What am I missing?
Thanks.


#2

This is not Gadgeteer board, no mainboard here…yet!

The best way to start would be a console application. Start by ouputport and blink an led.

We are trying to release an update tomorrow. Much has been fixed.


#3

Thanks for your reply.

Yesterday we ran a basic code. The connection problem was caused for connecting the module to an USB hub. The solution, plug it directly to the pc.
Best regards.


#4

Have you tried a powered hub?


#5

No, I haven’t.
Anyway, the hub is not necessary.

Thanks Gus.