Main Site Documentation

G400-D SD Card Debugging question


#1

First, this is not intended to be critical of the G400. It is only a general question for advice.

Using VS2010 and 2012 for Windows desktop (Both Express versions)

My application (in development for SD Card tests) requires that I must ‘reset’ the G400HDR almost every time when I try to start a Debugging session.

Example error message when using VS2012:

Attempting deployment…
Incrementally deploying assemblies to device
All assemblies on the device are up to date. No assembly deployment was necessary.
Assemblies successfully deployed to device.
Restarting interpreter…
Attaching to device…
Waiting for device to initialize…
The debugging target and the debugger engine failed to initialize because of unspecified device errors.
The debugger engine thread has terminated unexpectedly with error ‘Could not reconnect to the debugging target after rebooting it.’.

I notice that I lose the USB driver connection when rebooting. The new connection does not succeed.

(When debug succeeds the USB connection quickly comes back after rebooting)

Does anyone know what code usage would cause/aggravate this annoyance?

Yes… A loaded question, just looking for ideas…


#2

@ andre.m -

your application code…

Obviously. But I’m not that sure it really is…

I am not using loops and have removed all events except for two buttons.

One button is used to begin the tasks for the application the other is used to unmount the SD Card.

The removed most of the code and now only do some basic read/write to a SD Card module and display text and bitmaps. I receive no exceptions using the app and the tasks perform as intended.

I would be glad to blame my code but I cannot find any cause …


#3

@ willgeorge - I’ve same problem with sdcard attached. To start debug and deploy I need to disconnect sdcard and than pressing reset on g400 so I can start vs2012, but not always. Have you tried plain .netmf, not gadgeteer?
Your suspect about dropping voltage is not wrong.


#4

@ dobova -

Have you tried plain .netmf, not gadgeteer?

Not yet… I was trying to see if I could find the cause


#5

@ willgeorge -
for what I see, if I disconnect eth enc28 and sd card the board works fine.