G30 development board is not showing port in FEZ COnfig

I need help how can I update G30 development board firmware. When I open the FEZ config it responds but it doesnt show any port to communicate.

Is this a custom board or one of ours?

Are you using NETMF or TinyCLR?

Its GHI electronics G30 dev (not custom )board, using NETMF. I am also new to it.

What does Device Manager show please? Screenshot would be perfect

here is the screenshot

Did you follow the instructions shown in fez config?

If it appears as a NETMF interface, then you did not press LDR0 and LDR1 during reset.

Follow the instructions in Fez Config to put it into the correct mode. It will appear in Device Manager as a COM PORT if it works.

Thanks all for the support actually the instructions are bit of confusing. You have to hold the reset button same time while you are holding LDR01 and LDR0. But now in my VS2010 .netmf there is no transport devices are shown.

yes, this is correct, and expected. When you’re in LDR0/LDR1 mode, you’re only updating the firmware with Fez Config.

When you can see the “GHI Netmf Interface” in Device Manager, it’s in a mode that VS can see it.

So all you need to do is update the firmware with Fez Config, then reset the device in normal mode, and go about your programming.


The Firmware is updated and shows in my device manager but after I wrote the program and wanted to deploy into the device through VS2010 it does not show my G30 target device. How do I solve it?

Please go here http://docs.ghielectronics.com

Click on NETMF and then on getting started. This will get you to


And please follow the steps. Let us know where you have any issues please. For example, you need vs2013.

1 Like

Thank you Gus for the valuable information. It seems the VS2010 is not supported. One more question the display in G30 development board is dark and it is only powered by my laptop USB. Do i need to supply additional power 3-7v to turn the display?

If you look at the schematic for the G30 dev board, there is a GPIO pin to drive the LCD backlight. Try setting this HIGH and it should give you a nice bright LCD display.


1 Like