Main Site Documentation

G30 Dev Board Rev1.0


#1

Hello, I am interested in getting into the new TinyCLR (4th preview) I have downloaded the preview,
installed GHIElectronics.TinyCLR.VisualStudio.0.4.0 into my vs2017 installation.
How do I flash the board with the provided firmware? Do I use the netmf tools from before?
Is there a getting started page I should review first? any help is appreciated. thanks


#2

I do it the basic way, using teraterm with 1k xmodem.


#3

@ Dale Lyons - You could find some useful informations in this link: https://www.ghielectronics.com/community/forum/topic?id=24297&page=1#msg225257


#4

@ Bauland -

Link does not mention…

Bootloader Version 2.0+

Currently the G30, G80, G400, F20, and ALCAM use this version of the bootloader.
All commands and results are terminated with CR and LF (\r\n).

“OK.” will be returned after each successful command.

On startup, a banner is sent that is terminated by “OK.”.
Once the banner is received, you are free to enter any of the case-insensitive single-character commands described below.

Most commands require confirmation. Send Y or y followed by a new-line to proceed or anything else to cancel.
•V: returns the current version.
•N: returns the current device type.
•E: erases all user sectors of the device.
•R: runs the firmware if present.
•B: increases the baud rate in serial mode to 921,600.
•X: upload a file to the device using 1K XMODEM. Only send GHI provided files meant for your device with an extension of “.ghi”.


#5

ok thanks for that info.
I have the original G30 development board. How can I determine which bootloader I am running?
And if I need to upgrade what then?

thanks
dale


#6

ok, first off
do I connect the PC USB to the USB on the G30 board labelled “Debug USB” or the one “USB<->Serial”?
I get all kinds of random results on each.

I have managed to connect via terraterm and can query the Version (2.0.1)
and the Devide type (G30)
however attempting the file transfer always results in a hung board and locked up terra term
Can someone explain the proper sequence , which I assume is

  1. select the X command in terr-term.
  2. then vis XModem transfer the G30 Firmware.0.4.0.ghi file.
    (or the other way around.

Both approaches fails miserably.
any ideas?
thanks
dale


#7

Are you selecting the 1k option in the transfer? That’s usually the reason for failure, not doing that…


#8

@ Dale Lyons -

Brett post example


#9

thanks for the info but no joy
The transfer just stops on the first packet.

I have used bauds 9600,n,8,1 and 115,200,n,8,1
no luck

anything else?


#10

@ Dale Lyons -

If it were me I would use the E command to erase existing firmware and then try the X command.

But then again I just erase out of habit. Not sure it is really necessary.


#11

@ willgeorge - thanks for the tip but still no joy.

The E command seems to work fine takes about 5 seconds to complete but the file transfer still locks up on the first packet.


#12

What is your terminal version?


#13

Tera Term
Version 4.9.4 (SVN#6618)48 bytes()
I should mention that about once in 10 it makes it to packet#2 (2048 bytes)


#14

Get the 4.5.3 version from GHI’s site. link is on this page https://www.ghielectronics.com/docs/53/firmware-update-usbizi


#15

Victory!

Thanks everyone. firmware loaded … now the next step


#16

@ Dale Lyons -

Just for information:
I have been using Tera Term 4.5.3.
I just loaded Tera Term 4.94 ( SVN#6618 ) and it worked for me. G30 BrainPad.