Main Site Documentation

G120HDR Updater issue


#1

I have received my first G120HDR boards today and wanted to start clean by updating the devices.

PCB A
White screen (TE35 attached) at startup, and show’s in device manager as "GHI Boot Loader Interface(COM27)"
Started the G120 updater, update, all ok (screenshot a)

PCB B
Starts up with version 4.2.4.0 “Waiting for debug commands…” on the TE35
and shows in device manager as “Debuggable .Net Micro Framework Device” (see screenshot)
I run theG120 updater from "C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\Firmware Update"
Connect the G120, pull LDR0 and LDR1 to GND and reset the G120.
G120 reboots and show’s TinyBooter v4.2.0.0 “Waiting” on the display.
At this point the “Debuggable .Net Micro Framework Device” is removed in the device manager BUT no other device is showing up?
I woul expect the GHI Boot Loader Interface on a COM port but no device showing.
Then i pulled LDR0 and LDR1 to the 3.3V and execute step 5 on the G120 Updater but get the message "Can not connect to the device etc etc"
What looks normal to me because there is no detected device.

PCB C
Exact the same as PCB B

I already removed the drivers, switched USB ports, used a different cable, added external power source.
The actual boot loader look installed ok because PCB A was showing as "GHI Boot Loader Interface(COM27)"
I use 2.10 for LDR0 and 0.22 for LDR1.

What else should i check? Thanks.


#2

bringing LDR0 and LDR1 puts the device in GHI loader not tinybooter, right? Maybe you are connecting the wrong pins?


#3

I just follow the 5 step instruction “on screen” from the G120 updater application.


#4

The Wiki indeed say’s otherwise :

http://wiki.tinyclr.com/index.php?title=G120HDR_Developer

Tested as described on the wiki and result in the attached screenshot.
Device looks in Tinybooter on the TE35 but as device on the PC as debug device.
And G120 Updater can’t connect.


#5

@ David@ Emrol -

If you respect the LDR0 and LDR1 process, you should obtain this one reboot, not the GHI Debugging Interface (see atachment)

LDR0 and LDR1 to GND


#6

Yes, it “should” but works only on 1 out of 3 G120 i have here, thats the weird thing.


#7

@ David@ Emrol - How do you power your boards ?

Did you try without the TE35 that is really not needed to update the firmware. ?


#8

Also when we talk about ‘HIGH’ state, this not mean to 3V3, but only leave the pin in the air !


#9

Powerd by the gadgeteer USB Client DP Module, connected to USB and a 12v / 2 amp power supply.
I will try the open pins and no display in the morning and i also have some ideas for testing after reading the WIN8 topic on:

http://www.tinyclr.com/forum/topic?id=9798

I will trace with USB 2 and 3 ports and remove the winusb drivers.
I’m testing on a Win 7 64 bit OS that is used for EMX projects before.


#10

I have 2 push buttons connected to my G120HDR.
1st between reset and gnd (button 1)
2nd between LDR0/LDR1 and gnd. (button 2)
For FW update I do as follows.

  1. push and hold button 2
  2. push button 1 -> I hear the USB Device disconnected sound
  3. release button 1 -> I hear the USB device connected sound
  4. release button 2 -> now the boot loader devcie (COM?) should appear in device manager
  5. click Update in FW updater
    Sometimes this does not work the 1st time, so I just repeat it

#11

Maybe due to Win8 so… I’m on Win7x64 : never has issues !


#12

I also have Win7/x64 on my Laptop, on which I can update as described. My college has a Win8/x64, there it says for the BootLoader device ‘the USB Device can not be started’. The debug Interface works as usual.


#13

Have been playing for almost 2 hours with all possible sequences, no success…
So finaly i hooked up a EMX board to verify if bootloader is still working for the EMX and guess what … error on the USB Boot Loader interface…
This probably means the PC is the problem, i will try again next week on a clean laptop installation.


#14

@ David@ Emrol

May be you can try changing the port number “now #29” from properties, with another less than 10 like COM2.
Unplug, restart system, and last plug again… after may be the com port is going correctly.
good luck.


#15

Spent another 2 hours today… all scenario’s on a new laptop, then again on a clean desktop machine…
Always the same results, until i found the human error, i almost jumped out the window…

So for general pleasure I can announce that 2.1 <> 2.10 LOL ?


#16

Just to be sure :

Do you acces the PC directly or over Rmote Access ?
Do you have some energy saving turned on ? Sometimes it can cause USB to be less powered or more over unactivated when not use for a while…


#17

@ LouisCpro -

Problem is solved :wink:

“So for general pleasure I can announce that 2.1 <> 2.10 LOL ?”

I wired 3 G120 boards at pin 2.1 instead of 2.10 … causing these boards booting in thiny boot …

Human error still rules !