G120HDR update

Tried to update one of the G120HDR modules with 4.2 but I don’t think it get completed. This is what the updater give me:

– Log –
Connecting to device…
GHI Boot Loader Interface found at Port#: COM78
GHI Bootloader Version: 1.01

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erase successful!
Updating TinyBooter. Please wait…
Update successful!
Disconnecting COM78
No response from device

In device manager the G120 has “GHI Boot Loader Interface (COM79)” as driver.

Is there something wered with the USB driver?

I run W7 64bit.

See bold note in SDK announcement about manually loading the USB drivers please.

Which driver should I manually load for W7 64?

Windows says “no” to all drivers except bootloader driver

Found the problem, it was ME :wink:

Forgot to releas the G120 from bootloader after reset…


I have the same problem:
SDK Version 0.0.6
October 24, 2012
G120HDR V1.1

@ Gus: Which SDK anouncment do you refer to?

@ Honken: what do you mean by ‘Forgot to releas the G120 from bootloader after reset…’?
I have tried to remove Gnd from P0_22 and P2_10 before Reboot during update, but that makes no difference.

Thanks, Reinhard

Please see the red note under the SDK download http://www.ghielectronics.com/support/dotnet-micro-framework

Wow, that was quick,

I didn’t recognize that there was an G120 USB Device in the Device Manager without a driver.
Installing it did the trick.
Thanks a lot.

I’ve succesfully update the G120HDR to firmware version then I removed all the wires needed for the FW update and connected it to USB, but it’s not showing up in Visual Studio neither in MFDeploy.

I’ve checked in Device Manager and it’s listed as “GHI NETMF Debug Interface”, I tried to manually update the driver but it doesn’t changed anything…

Now the device boot up and shows on the TE35 the following text:

Debug: USB1
LCD: 320x240

Waiting for debug commands…

What should I do now?

Hi, you said the device was listed in Device Manager, but was the driver functional ? Or was it not recognised?

It is recognized and everything seems functional