Main Site Documentation

G120HDR-Rev2 problems with firmware update


#1

I just bought and received a G120HDR-Rev2 module. I got it running, deployed my first application and everything worked fine till I received messages that the assemblies on the module were outdated, so I had to perform a firmware update.

Here I started by using FEZ Config, which deployed the firmwares and than ran into an error (cannot boot application or something). Looking through the forum I found out this was related to an outdated TinyBooter firmware, so I downloaded TeraTerm and looked up the firmware on my computer. After booting the module in the TinyBooter mode, I erased it (command E and Y) and after that started a file transfer (X). However, every deployment of the firmware ends again by showing ‘BL’, which is stated in the manual that this indicates that the firmware is not flashed correctly. Pressing R (run) also gives the message ‘Bad firmware’, so I cannot use the module at all at the moment. I already tried to reinstall the sdk to check for problems with damaged files, tried all my usb ports and flashed it already several times but still no luck. Whether or not using an external power supply does not make any difference in the result so it is also not related to this.

Has someone any idea what I am doing wrong or what is missing in this procedure why the firmware won’t flash in the correct way?


#2

After a fifth try this morning it worked, not with TeraTerm but by using the old firmware updaters on the website. I’ve tried that before last night already without success, but as tip for everyone who maybe can have this problem in the future, watch the usage of com-ports, if a program is using it already another program can’t connect and if you can’t connect at once just try to reset the module again till it works.

Also, why TeraTerm didn’t work I still don’t know, but it looks like there is some flaw or problem with it when using under Windows 8 64bit or maybe something has changed why this didn’t work.

And finally, when it won’t work, keep trying, once it will as I found out now…