G120HDR in ***** ASSERT *****


My G120HDR is showing ***** ASSERT ***** on LCD.

Here`s the code

public static void Main()
// get then logo
Bitmap logo = Resources.GetBitmap(Resources.BitmapResources.logo);

        // Scale to supported width and height
        Bitmap scaledLogo = new Bitmap(Configuration.StartUpLogo.SupportedWidth, Configuration.StartUpLogo.SupportedHeight);
        scaledLogo.StretchImage(0, 0, logo, scaledLogo.Width, scaledLogo.Height, Bitmap.OpacityOpaque);

        // Set the logo. The logo position will be the lower right corner.
        Configuration.StartUpLogo.Set(scaledLogo.GetBitmap(), SystemMetrics.ScreenWidth - Configuration.StartUpLogo.SupportedWidth, SystemMetrics.ScreenHeight - Configuration.StartUpLogo.SupportedHeight);

what I tried : Look at device manager and update the usb driver( in device manager everything seems to be ok with the driver)

then I tried to update the erase the program but the device does not response! I tried with g120 updater and with MFDeploy.Both can not communicate with the device, no ping!
Finally I tried to Update de firmware with g120 updater but the device is not responsed.

Startup logo feature is not working properly yet. We discovered this few days ago and working on it.

ok and what can I do from now to connect to my device?

For now just remove the lines that call startup logo.

unfortunately I can’t connect with the device anymore since that time. I tried with the MFDeploy I’m not able to ping the device and finaly I tried with the G120 Updater same thing no ping! I have a failure - Device G120_G120 is invalid or not responding.

Hold ldr pin low to enter tinybooter mode the use mfdeploy and hit erase.

Do you mean P2.10 and P0.22 connect to GND?

@ Mano

Yes Pins P2.10 and P0.22 but only connect P0.22 to GND. The other pin should be High. Here is a link to the G120 brochure for further details:

Thank you guys! I’m back on track with my device!