Main Site Documentation

G120HDR - Device is not connected or responding


#1

I recieved a g120HDR and programmed TinyCLR version 4.3 and now I cannot communicate with the device. When I bring up FEZ Config, it appears to recognize the board, G120_Gadgeteer. If I click ping, I get Failure - Device is not connected or not responding.

FEZ Config 2.0.6.0
Microsoft .Net Micro Framework 4.3 (QFE1)
NETMF and Gadgeteer Package 2014 r5

The board is connected to my computer using the USB Client DP Module and a power supply.

I tried different installation on different computers.

How do I recover the board?


#2

@ tbambrough - have you tried to deploy a program? That is a better test.


#3

Nope
The device is not responding.


#4

might be a long shot, but can you check device manager and see if the device shows up there successfully, and that it doesn’t “ping pong” with device disconnect/reconnect noises ? That may indicate a power problem but will also confirm the device driver is loaded properly.

Also I’d test against MFDeploy as that’s a MSFT supplied tool, even though Fez Config works reliably in normal situations…

You can check https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting for more options as well…

And I would lastly suggest you try booting into bootloader mode and reapply firmware and see if that brings back stability.


#5

@ Brett -

I think that is best way… :smiley:


#6

If you update firmware from 4.2 to 4.3 and you do only a firmware update and not the bootloader update you get this situations like this.

Boot up the device in bootloader mode and update device with fez config - advanced - loader (TinyBooter) Update - G120 (FEZ Cobra II) will fix your problem.

Make sure you see the device in bootloader mode in device manager.