G120E Stuck in Bootloader Mode

During development testing and code updating my G120E stopped responding and is now stuck in TinyBooter mode.

I’ve tried to reload with FEZConfig but no success (Gives USB driver error…)
Even tried with Teraterm that gives Bad firmware error.

I’ve seen similar posts but no direct solutions.

My Config:
FEZConfig V4.3.7.10
NETMF v4.3:
EMX: Firmware, Loader
G30: Firmware
G80: Firmware
G120: Firmware, Loader
G400: Firmware, Loader
Cerb-Family: Firmware, Loader
FEZ Hydra: Firmware, Loader

Any suggestions / solutions?

I’ve updated a previous EMX without any issues to confirm my setup.

@ DanB -

  • Enter Bootloader mode
  • Open teratem
  • Select correct port
  • Type “E”
  • Type “Y”
  • Wait for “Done”
  • Type “X”
  • Point to G120\Loader.ghi (select 1K)

Have you done those? If so, change to serial mode and try again.

The suggested Teraterm procedure is exactly what I did plus all the permutations and different versions and PC’s.
On a few EMX’es this all work 100% but this G120E is buggered.

I found previous posts with the same unresolved issue…

(I’ve done most of these suggested actions without success)


:wall: :wall: :wall: :wall: :wall: :wall: :wall: :wall:

@ DanB - To be sure, have you reinstalled the SDK to make sure the firmware is not corrupt?

@ John - I’ve downloaded the latest GHI Electronics NETMF SDK 2015 R1 again, Installed it on a fresh Win10 PC… the result is the same.

It was running for 2+ weeks on the G120E anyway… before the malfunction. Our main concern is what caused this because we cannot afford this to happen with our production units.

@ andre.m - Yes that is correct. C:\Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Firmwares\G120\Loader.ghi
Using FEZConfig as well as the Teraterm procedure!

@ DanB - In your TeraTerm screenshot, there are two separate uploads of different lengths. What were they?

@ John - You mean the C’s ? That is the waiting C’s for transfer selection after pressing X for Xfer… The file selected on both occasions were the same.

I am receiving a replacement G120E in the morning and hope to be up and running in no time. I’ll send this module back to the supplier for “evaluation”.

@ DanB - Sorry, were they the same file? If you erase, upload, and try to run, it fails every single time?

@ John - YES. Same file multiple times. Did even try different baud rates.

Dan, the reason for the question is the third post on page 1 of this thread, where you posted an image of the terminal output, clearly showed transferring two files, including one transfer that was successful. If it was successful, why did you then erase it and try re-doing it?

@ Brett - After the first Xfer (X) I did not Run ® the target but decided to display the bootloader Version (V) and repeat the process of erasing (E) and Xfer (X) . It allways show successful after transferring but return with BL indicating failure. As soon as the Run ® command is entered is confirms this by giving Bad firmware error.

Can you confirm this “BL” indicates error after transferring.

I’d just go back to Dat’s post and follow the bouncing ball and not mess with the process. Follow it to the letter and report back if your device works correctly or not