Main Site Documentation

G120 Rev C on custom Board => No Link on USB Host


#1

Hi all,

I received my new G120 based custom board today, and tried to start playing with. Unfortunately, When I plug the USB cable, I have no reaction from Windows to install any thing !

It would be nice if someone could have a look at the linked schematic and tell me back if I made a mistake in the way I implemented the USB…

thanks


#2

An information more : I tested the link with my metrix and bip correctly between the plug and the G120 pins fo D+ and D-…


#3

Do you have it in higher res? it’s too small to read…


#4

I get a similar issie with the ChipworkX module in my custom board.

If I plug it in with the board powered up, nothing is detected by windows.

If I have it plugged in and then power up the board or reset it, Windows detects the USB.

Does Windows detect if you reset or power up with the USB in?

I can’t make out your schematic too well but I spotted that same as I have. USB power is not connected to anything other than the ESD protection IC. I have another supply for the system. USB is only connected with D+, D- and GND.

I looked at the Cobra II board and didn’t spot anything different on that.


#5

@ LouisCpro - I am happy to have a look but like Justin ask, a higher res image would help.


#6

Hi,

Looking at the low resolution schematics, it seems there is a mistake on your board.
You’re trying to connect to the PC via the G120 host port and not the device port.
G120 does not support USB OTG.

S.B.D


#7

I had my first 10 proto PCB’s V0 with the G120 last week, with USB Client and USB host connections, worked after a few hardware bug fixes so it should work if design is correct.


#8

Hi All,

Thanks for your several feedbacks. It seems that S.B.D is on the right way with mistake between USB Host and Device…I’m making some changes on the PCB to test that and will bookmark if this is the solution…

…In the meanwhile, it seems that I do not receive your replies by email however i checked the “Watch this topic…”.

I will post on the forum bug report…Does any one noticed that also ?


#9

@ LouisCpro - The email issue is mentioned by others too


#10

@ RobvanSchelven -

OK, but SBD is the nearest and It would make sense if I help a newbie, don’t you think ?


#11

@ S.B.D. -

Right !

USB has to be connected on Client side (G120 PIN 66 and 67) not Host… Rotting mistake corrected and fine now !

Several couple of eyes are always better !


#12

@ LouisCpro - although i am bold, i feel blond :wink: not sure if i understand your response. What i meant is that more people did not receive an email even while they checked the “watch this topic”


#13

OK,

The link between my 2 neurons is now connected !

I thought you were talking about the USB issue, as it was about the “Check reply”…

You’re not blond… I’m !

:clap: