G120 not booting at startup

I’m touching base with the community to see if someone had G120 boot issues. It doesn’t happen often, 1 time over 40 boot. But for a mission critical device, it is too much.

On our custom board using the G120, we have a slave SPI device connected to the G120. For some reason, the code never goes to user code. I can confirm the G120 is stuck (frozen state) before it reach user code.

Are there any IO lines that need to be to a specific state? I checked the reset input architecture of the LPC processor and it has brown out reset (BOR).

Could it be the Bootloader or the netmf OS loading that freeze?

Any comments or potential solutions would be greatly appreciated.


I’m having some strange boot issues myself that I’m still trying to figure out. Are you using pin P1_30? According to the documentation, Pin 59 P1_30 AD4/COM4 OE must NOT be grounded on power-up for GHI Bootloader to function correctly.

Hi Dan,

Currently my pin P1.30 is floating(not used).
Could you indicate me on which documentation you read this note?

Do we have to install a pull up externally ?

thanks for your reply,


@ TheProbe - It’s on the bottom right of page 3 with the ** next to it. http://www.ghielectronics.com/downloads/man/G120_Module_Brochure.pdf

I have it floating myself and the HDR model has it floating too http://www.ghielectronics.com/downloads/schematic/G120HDR_RevC_Module_SCH.pdf

1 Like

@ High-Speed Dan -

** Pin 59 P1_30 AD4/COM4 OE must NOT be grounded on power-up for GHI Bootloader to function correctly.

I will with GHI team to ensure we don’t need an external pull up? That may explain why the problem is intermittent.

Thx Dan. I will update you on any thing I find on this booting problem.

Best regards

@ TheProbe - I built my boards before this note was even there. By chance I didn’t use this pin. I’d be interested myself to see what we should be doing with it if anything.

Good luck Sebastian!

Hi Dan, I will keep you informed for sure.

Very best,

I got the same error with a G120 on a custom board. That pin was also floating. I even tried to replace the SMD FLASH chip and no success.

Ended up buying a new G120 and desoldering the old one. Was cheaper than sending it back for testing.

Someone else had this issue and we never got it figured out.

I had issues like this with devices connected to the SPI bus that used a CS pin that by design was assigned to the LCD. Also turned some G120 modules to spare parts :wink:

Was there ever any followup from GHI on this post? I just built 10 custom boards based on the G120 and 2/3 of them have this behavior. They appear dead. No USB connectivity and can’t get them into booloader. Their current consumption appears normal @ ~110ma compared to modules that have not been assembled yet.

Are the G120 module particularly tricky to reflow? Is it unreasonable to suspect bad modules? I would sooner believe I am the reason, but it’s a pretty simple board and I don’t normally have issues assembling boards. I just can’t reconcile whats wrong here. What is the best way to tell if these module are really dead?


@ Superpanda -

Is it in serial mode debug?

P2.1 is floating per the schematic of the Cobra II boards.

@ Superpanda -

just for testing to know what your boards status is.

  • Connect that pin to VCC and try USB?
  • Connect that pin to GND and try serial USB?
  • Did those boards work before?

I’ll give that a try. Serial will be a little tricky as I did not expose those pins on on the board, but I’ll try and rig something up. The G120 Modules are straight from packaging so I can’t say if they worked before I got them or not. The boards “work” in the sense that some number of assemblies do not present this issue. They are fairly simple in design so I do not believe the boards are the root issue.


@ Superpanda -
After that, if you still can not communicate with those board, you can contact support@ ghielectronics.com to request RMA for the bad boards, we will take a look at them.

Pulling MODE pin high and testing USB again yielded no change in behavior. No connection possible.

Pulling mode pin low and checking the TX (P0.2) pin of the G120 module I do see activity with a scope. A constant pulse every ~100ms. This activity is not present when the MODE pin is high or floating.

When I connect via serial with TeraTerm I just get constant output of “55555555555555555555555555555555555555…”.

Using MFDeploy or FEZConfig I can’t make a connection over serial, but I do get the same output back. See output from MFDeploy below:

Pinging… NoConnection
Pinging… NoConnection
55555555555555Pinging… NoConnection

I assume the “55555” is the pulsed output I see on the P0.2 TX line?

Tried this with 2 of the “bad” modules. Same result.

Otherwise, this really makes no sense to me. I am afraid to buy more modules and build more boards until I know whats going on.


@ Superpanda -

Can you tell me that is G120 or G120E module, please?

They are G120’s. Purchased from Mouser last month.

@ Superpanda -
Your test result doesn’t make sense to me.
if you can send it to us, we will try to find the answer.

Can you take a picture how you installed the G120 module to your board (of course, if that is not your business secret)

@ Dat - I agree, does not make sense.

You mean send one of these “bad” G120’s to you? Just give me the details where to send etc.

Picture if the G120 installed on the board is attached. The picture makes it appear it not aligned on the pads, but in fact it is perfectly aligned. If you want the eagle files just let me know where to send them.