Main Site Documentation

G120 Loading firmware


#1

I’m currently reviewing the G120. What I see is that, in order to download firmware, you have to manipulate 3 pins. P2.10 & P0.22 must be connected to ground instead of 3.3V and the MODE pin must be connected to 3.3V instead of GND (in case of USB). Really, this doesn’t simplify things.

I would need to be able to go into download mode with a single, small, SMD button (as I did on the EMX by tieing the 3 update pins togetter). Will entering firmware download mode be simplified in future, so a single button firmware download can be made possible?


#2

Aren’t you mixing things? Mode pin has nothing to do with update, it is USB vs serial but the pin has a built in pull up so leave unconnected and it is USB :slight_smile:


#3

I just started the G120 updater and read step 1-3 :slight_smile:

I also thought that the MODE pin should be tied to GND for USB? See http://www.tinyclr.com/forum/topic?id=8644


#4

And that is why we should not talk about product before it is released :frowning:
See here http://www.ghielectronics.com/downloads/G120/G120%20Module%20Brochure.pdf the pin is USB/COM1#, the # symbol indicates low.

We will clear this up some more and same for the updater app.


#5

Hi. I am bringing up my development board with the G120 module. I was initially able to enter into “Bootload” mode by pulling LDR0 (pin 8) and LDR1 (pin 14) to GND. I then gave the board to my software guy and the module would not enter into bootload. MF Deploy sees G120 if both pins are high and I can enter into “TinyBooter” if I only pull LDR1 low but I suspect I need to be able to enter bootload using TeraTerm in case I need to update TinyBooter. Does anyone have any insights?


#6

Du you have a display connected? If yes check what mode the G120 is starting, you have 3 modes :

Firmware (both pins high)
Tinybooter (only ldr0 low)
GHI Bootloader (both pins low)

If you make a mistake and pull 2.1 low instead off 2.10 you get in Tinybooter mode (don’t ask why i know… but i will never forget)


#7

I don’t have a display connector integrated yet but I can use MF Deploy. If I leave both 2_10 and 0.22 high then MF Deploy reads G120_G120 and if I ping it then it responds TinyCLR. If I pull only 0.22 low MF Deploy reads G120_G120 and if I ping it then it responds TinyBooter (with GHI copyright info). If I pull both pins low then MF Deploy does not see the device and neither does TeraTerm. Again, I’ve used TeraTerm with this exact device and read the firmware version. My software guy attempted to load a new file and it hung up so I’m wondering if something happened in that process. I’ve erased using MF Deploy with the same results.


#8

What you see in the device manager if you boot with ldr0 and ldr1 low?
You should see bootloader device showing up in the com port section.
Maybe the driver is not detected / loaded correctly.


#9

There is nothing in the device manager with LDR0 and LDR1 low. Other configurations show G120. I’ll look into the driver issue but I’m not sure why it worked initially and now it doesn’t…I didn’t delete or change drivers. Anyway, I appreciate your help David.


#10

I have a few G120 breakout boards and these boards both show up in Device Manager as “GHI Bootloader Interface” when LDR1 and LDR0 are pulled low. So it is obvious to me that something has been corrupted in the GHI Bootloader Firmware on the module that is on my development board.

Gus (or anyone), is there any way to reload the GHI Bootloader Firmware onto my module?


#11

Open the virtual serial port using a terminal software. Then enter V to verify you are getting back the version number. From there, you can try R to run on X to load TinyBotter.


#12

Well… I have exactly the same behavior today on 3 V2.0 proto PCB’s…
The V1.0 worked like a charm and the G120 modules are from the same purchase so something else must be wrong. We think we maybe “overcooked” the G120’s because on the V1.0 board we soldered them manual, the V2.0 was done in the reflow oven where we had to extend time for big cap’s that seem to absorbed allot off the heat.

I used both the USB and COM mode and in both cases the updater is unable to update the board. We are going to start a clean PCB in the morning with just power and the G120 connected to the USB Client interface.

I have a check first with teraterm and keep you posted.


#13

This isn’t a good start with my G120 experience.

David, I don’t think you have overcooked the boards because my one board worked and then stopped working. I also soldered by hand. I’m going to try my second dev board in the morning so I’ll let you know what happens and check back to see about your success.

Gus, the whole problem is I cannot communicate using terminal software. I could initially and now I can’t. I can enter TinyBooter and I can run it normally but I can’t load software until I have the latest firmware.


#14

I must say I already been in different “pitfalls” but at the end it never was a problem with the GHI device itself, so I’m confident this will work (at the end), even more because I had no problems with the V1.0 PCB’s.


#15

We have placed thousands of G120 modules already, no issues.

You can always remove the module off the same board, then place one by hand to see if the module is in fact overcooked?


#16

We are in the process doing this. I show pictures tomorrow :smiley: how a G120 looks after it’s been removed with a “heat gun” :smiley:


#17

Sun burnt? :whistle:


#18

“Ikea” versions :smiley:


#19

hahahaha - so lets see the cooking - curious to see how you get on removing them…


#20

I installed a different G120 module on my second development board and it works just fine. It appears something has either fried the LDR0 pin or the firmware is corrupted. I’m currently removing the module from the first development board and will install another one. I’ll reply with results.