Main Site Documentation

FW update problem


#1

One of my custom boards died last night after/while loading a new use code.
I can ping Tinybooter.
Using both MFdeploy and GHI util, I can finish deployment with what looks like a signature pass.
GHI’s debug driver does not load - :frowning:

What else can I try except replacing the module.

Thanks,
S.B.D


#2

@ andre.m

Thanks for your reply.
This is what I did.

GHI update utility always gets stuck on the last reset after FW deployment.
Using MFdeploy I get a signature pass after FW deployment - but after that device is dead.

Tinybooter can always be pinged if I boot with LDR1 low.

Thanks,
S.B.D


#3

@ S.B.D. - do you work like this:

LDR0 & 1 LOW
hard reset board
LDR0 & 1 HIGH
Flash using GHI update utility


#4

@ RobvanSchelven

Yes, this is how I tried it with GHI util.
I also tried with MFdeploy (LDR1 Low on power up).
Both seem to pass the deploy stage, but GHI debug driver not in sight.

Thanks,
S.B.D


#5

@ S.B.D. - What do you mean by “debug driver not in sight”? Do you mean after update flash, reset the device. you can’t access the device from for example Visual studio to deploy a managed application?

Are you aware of the availability of WINUSB driver “C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_WinUsb”


#6

@ RobvanSchelven

Yes - after deployment, I can’t see the USB driver load on the device manager.

Other boards work on the same PC so I don’t think its a driver issue. The PC doesn’t see any USB connection at all from the faulty board.
It doesn’t “gling” when I connect the USB :slight_smile:

I am sure that the HW is OK since I can ping TinyBooter.

S.B.D


#7

@ S.B.D. - I guess you need to discover whats wrong with the faulty board :wink: dip switch remain closed, shortage :frowning:


#8

@ RobvanSchelven - Just discovered that Fez updater V 0.1.3 did not detect my G120 while V.0.0.3 did. :frowning: Not sure if V 0.0.3 is available for download at GHI website, otherwise send me an email if you want to give it try. My forum name at gmail dot com


#9

@ RobvanSchelven
I don’t think this will help since I don’t see the G120 USB device enumerate at all on the PC, so the application no matter what will not be able to detect it. Is my logic correct.

Anyhow, I sent you an e-mail - please send the app I’ll give it a try before pulling the module out.

@ GHI - Can you assist?
Is it possible to buy just a pre-programmed serial flash and not buy a new module?

Thanks,
S.B.D


#10

I managed to solve the problem by replacing the assembled G120 serial flash with another one from a dead G120.

@ GHI - Can you please give a short explanation on where GHI bootloader, Tinybooter and TinyCLR are stored (internal or external flash memory)?

Thanks,
S.B.D


#11

Very unusual. Getting into the ghi loader and erasing all should have solved the issue.


#12

@ Gus -
Yes I know. I tried multiple times with all updating utilities know to man :slight_smile:
It always passed deployment verification but USB port was not functional after next reset.
After the serial flash replacement, I used GHI’s Utill and it worked the first time around.

Can you explain where the different code sections are stored?

Thanks,
S.B.D