Font Converter ver 2.0.0

I downloaded the Font Converter tool with much difficulty since it says the exe is not usually downloaded. I tried to run it but I got no results (even if I tried to run as a command line app). My question is how do I run this app? If I can’t run it, can anyone direct me to another download site?

Do you have the execute file yet?

I found a link that allowed me to download an application named “TinyFontToolGUI.exe”. I believe this app will allow me to convert fonts. However, I have discovered that I have a bigger problem I need to investigate.

The original file name has to be “TinyCLR OS Font Converter v2.0.0.exe”. When you download this file, the browser asks you to keep or delete, you should choose to keep the file.

For the other file that you downloaded, we don’t know where this one come from or what this file use for.

Thanks Valon,

I already have this app which I intend trying (the second link I mentioned above).


Hi Dat_Tran,

I tried renaming the downloaded file exactly as you described but was unable to run it.


my take is you are downloading the wrong file, and renaming it is irrelevant. Where do you think you downloaded it from?

I’ve just followed the bouncing ball here and the app works fine for me.

I went to the TinyCLR OS files on the download page link and then downloaded the Font Converter 2.0.0. I’m using Edge on Win11. The direct link to the file is here. Since that’s a HTTP link not HTTPS, Edge reports it can’t be downloaded securely. I click the ellipsis, keep, and keep anyway. It’s then a not-signed app so I’m prompted again, from ellipsis select Keep, Show more, keep anyway. Then, the app is available to me in the Downloads folder. From there, it’s a command line app so open Windows Terminal (or powershell or cmd, all work the same) and navigate to the appropriate folder and run the app. Example output from this when I don’t supply params:

PS C:\Users\brett\Downloads> & '.\TinyCLR OS Font Converter v2.0.0.exe'
Missing parameter for option '<input file>'

FontConverter - .TTF to .TCFNT conversion tool

Converts a TrueType font into .tcfnt file for TinyCLR.


    FontConverter <input file> <output file>
      <input file>  = Font definition file (.fntdef)
      <output file> = Font output file (.tcfnt)

1 Like

Hi Brett,

I followed the direct link to the file you provided, and it worked just as you described :slight_smile: :
Thanks for your help.


1 Like

Hi Brett,

I am trying to use the font converter app to generate a usable TinyCLR font, but I am having some trouble. I renamed the font converter file to ‘TinyCLR_Font_Converter.exe’ to make things easier to type and entered using the DOS prompt:

        c:\tinyclr\fonts\TinyCLR_Font_Converter.exe micross.ttf micross.tcfnt

The app accepted this input and simply went back to the dos prompt but did not generate anything. What am I doing wrong?


Look at the working folder to see if a new file is generated.

Hi Dat_Tran,

I have looked at every folder I can think of and I do not see any files generated.


You need a config file. I don’t see the config file in your command.

The original font is *.ttf
The config file is *.fntdef
Example, you want to convert Arial Black, the command to build is:

TinyCLR_Font_Converter.exe "Arial Black.fntdef" "Arial Black.tinyfnt"

Arial Black.fntdef: The config
Arial Black.tinyfnt: The output.

You don’t need input file for original font, just place the original font file in same folder with the fntdef (the config file).

Here is an example for Arial Black config, save it into a file called Arial Black.fntdef,

SelectFont "FN:Arial Black,WE:900,HE:36,IT:0"
ImportRange 32 126

Then you copy “Arial Black.ttf” from your font folder (somewhere C:\Window\Font… - depends on your OS) to your working folder.

Then run the command above. A new file “Arial Black.tinyfnt” will be generated and this is what you need to add to your resource of the project.

Change the config above to get smaller, bigger…

The doc here Font Support (