Main Site Documentation

First time using Gadgeteer - Cannot update firmware


#1

Hello

I discovered this part of the world recently and am now playing with a FEZ spider.

I have managed to write some simple code for the spider in Visual c#, but it says the firmware is the wrong version.,

So I have used fez config and it says I have no firmware… When I go to update the firmware, it gives me a problem.

IT goes to check the signature of the device and it fails everytime. I cannot figure out how to update this manually as everytime i do my research, i end up on the same support page…

Some photos are attached, anyone have any ideas for what the problem could be?

Thanks


#2

BTW, i did not unplug or touch anything…

Not sure why it says interrupted.

I have done it yesterday and today over 5 times, and it gives that error everytime


#3

Thankyou for the welcoming and quick response…

I had tried this before, but thought id re-download and try again, just in case…

and its worked and says it updatec both booter and firmware… although under fez config it still says:

"
Connecting to device…EMX_Gadgeteer
Loader (TinyBooter) Version: 4.2.11.0
Firmware (TinyCLR) Version: Not available.
Connecting to device…EMX_Gadgeteer
Loader (TinyBooter) Version: 4.2.11.0
Firmware (TinyCLR) Version: Not available.

"


#4

And let me just add that I have never managed to update Spider firmware with anything else than Teraterm… the legacy updaters only works for some people.

Check the https://www.ghielectronics.com/docs/54/loader-tinybooter-update-with-teraterm and stay focused when doing it. Its easy if you concentrate, and keeps re-trying if it fails. I normally try 2-7 times before succeeding.


#5

hmm, cross posted. It looks like you have the right version of tinybooter, but needs the firmware. That part should be easy with FezConfig013, so I dont understand what might be the problem.


#6

Yeah, I have latest SDKs

I managed to update firmware with Fez Config so its now got

Tinybooter version: 4.2.11.0
Firmeware TinyFLR version:L 4.2.11.0

Although, the name of my device has changed from EMX_Gadgeteer to EMX_EMX is this a problem?


I have tried to run a simple program in visual c# although I now get the eriorr that it cannot see the device


#7

Yeah, worked perfectly.

Thanks for the quick help everyone. Now I can just experiment and have some fun with this thing.

Thanks a lot!


#8

I’m not @ work right now, and I don’t have a device to connect here; so, this is from an old guys memory: if you want to avoid the usb->serial, serial->usb switching, go into FEZ Config, go to Deployment Advanced, where it says “friendly name” make sure it says “gadgeteer”; if doesn’t enter it that way. Tell Fez config to do it. – The friendly name is part of the USB name and will allow visual studio to (in most cases) recognize your device automatically.


#9

@ Jeff - note to self: need to document this even though next version of FEZ Config will do it when it updates the firmware.