Main Site Documentation

First Cerbuino run


#1

Well, It’s not the first trail, but it will not let me debug it.

Clicked my first Gadgeteer project together with the graphical interface.

Can run it with emulator, and also with attached device.

My problem is that it looks as if all is loading (even the debugger), running and exiting with code 0x0 I can’t get any break point to stop the program.

For instance a breakpoint in

public static void Main() {
// Important to initialize the Mainboard first
Program.Mainboard = new GHIElectronics.Gadgeteer.FEZCerbuinoBee();
Program p = new Program();
p.InitializeModules();
p.ProgramStarted();
// Starts Dispatcher
p.Run();
}

turns pale during the run time and the program will not stop to let me tab through how for instance the main board is initialized.

Same for the modules and for

void ProgramStarted()
{
Debug.Print(“Program Started”);
}
.

I am lost…
probably a stupid little setting somewhere

Thanks


#2

Not both, can you check your project properties and ensure that you have selected the board and not emulator ?


#3

Just make sure you can see the OUTPUT window in VS. That is where the debug statements get printed, and if you can’t see it then you may not know that it’s working correctly… And if you can see it but don’t see the debug.print statement, capture what it shows and paste it here as it will probably help understand what is going on.


#4

Thanks guys,

I am not sure what happened but it works now…

I am aware of the output window but like I said, as soon as I ran the program my full body red breakpoints turned into red circles and never sopped the program.

If it happens again I will report with more details.