Main Site Documentation

Firmware upgrade possible with Windows 8?


#1

I just found my FEZ Domino, and it has firmware v4.1.3.0 (15-Oct-2010).

I installed the USBizi updater and followed the instructions (hold LOAD button, press and release RESET).

The device shows up in Device Manager as “GHI Boot Loader Interface” (COM3).

When I press the Update button in the USBizi Updater, I get:

[quote]-- Log –
Connecting to device…
Cannot connect to the device! Follow steps 1 to 3
[/quote]

I am running the release version of Windows 8 (64-bit).

Can you please provide guidance on how to update this device?

Thank you,

Chris


#2

We will be doing some testing on windows 8 once it is out for everyone. As of today, it may or may not work.


#3

I am running the release version of Windows 8 (64-bit).

Can you please provide guidance on how to update this device?

Thank you,

Chris
[/quote]

Chris, I don’t have a Domino, but I was able to update one of my Cerberus boards just fine on Windows 8 using MFDeploy, and I’d successfully done firmware updates on my other boards from Windows 8 RP.

Two things that might be worth trying are running the updater as admin, and running in compatibility mode. And if you haven’t already, might be worth trying a different USB port.

Might also be worth pinging Pete Brown, as I think he has a Domino and might be able to verify if the firmware update works for him.


#4

Is there a manual procedure I can use as a workaround in the meantime?

If not, I can put this board away for a while until Windows 8 is supported. No worries.

Thank you,

Chris


#5

Hi devhammer,

Good advice, thank you.

I tried all the scenarios, but it looks like the latest GHI boot loader serial driver might not be compatible with Windows 8. I also tried to connect via TeraTerm and HyperTerminal, but neither could open the port.

Chris


#6

Yes http://wiki.tinyclr.com/index.php?title=Firmware_Update_USBizi


#7

Hi Gus,

I tried that process too, but neither HyperTerminal nor TeraTerm can connect to the serial port under Windows 8. TeraTerm doesn’t show COM3 as an option; and while HyperTerminal does show COM3, it throws an error when I try to connect.

I assume that the firmware updater is having the same troubles connecting to the boot loader serial port.

I’ll put away my NXP-based FEZ boards until you’ve had a chance to test and support Windows 8; this is not a blocking issue for me at the moment.

Chris


#8

I have just downloaded Windows 8 Release Preview 64 bit, and was able to update the firmware to a FEZ Domino without issue. If you are still having problems, try starting out with the board unplugged from the power source, hold the LDR button while plugging in the USB cord.


#9

Hmm, that’s really weird. I wonder if something changed between the Release Preview and RTM.

Thanks for the tip on booting the board by pressing LDR while plugging in the USB cable; that’s a good troubleshooting tip. I did try that and had the same issue.

Chris


#10

I’ve recently built a new Win8 RTM build x64 machine, and I’ve just set up the newest RC of the GHI SDKs and updated a Panda with the 4.1 firmware in that SDK bundle. Worked fine.

I had device manager open when I was connecting the Panda. First up the debuggable .Net device appeared, as expected. Then I held LDR and hit reset, the debuggable device disappeared and COM ports became visible and there was the com port (com4 in my case). The Updater found the port and everything.

Chris the only thing I can suspect is that from memory the driver installs per-user, and perhaps you didn’t install it as the same user you’re running under? I chose All Users when prompted, so perhaps the difference?


#11

I have the same problem. Can’t connect FEX Panda ii on Windows 8 64.
It works fine on Windows 7 where I did the firmware update.
Any idea?

Thank you!
raresh.


#12

It works, after installing winusb and restarting (twice :))
Thank you!