Main Site Documentation

Firmware Update Problems - Not recognized in Loader mode


#1

Start a new thread to avoid the continuing hijacking of the MS guy’s thread.

Installs fine and I can deploy through VS 2010 to it (MF 4.1).

Trying to upgrade to 4.2 but the flasher won’t recognize the hardware (Windows finds it, fails to install driver) after restarting in loader mode (1,2,3 on dip switches). Even manually selecting the Boot Loader interface driver won’t take.

Originally thought it was a dodgy dip switch. So, I bought another FEZ spider kit from the same local distributor. Same issue. I’m going to refrain from buying a third.

I followed the manual process and the TeraTerm path, nothing works. I’m now at the point of trying a different PC (I have another Win7x64 laptop or a WinXPx32 to try). Current PC is Windows 7x64, using USB2 (straight from M/B) without a hub.

Any other suggestions? Is the 4.2 update process stable? I’m going to eventually run out of PCs to try.


#2

I got new fez spider today and I have the same issue. In my case windows says the usb device failed and show it as unknown once I set switches on and reboot. I would not move to 4.2, but with 4.1 I still have the problem with no modules and mainboards available in designer :frowning:


#3

While USB specifications say ports should provide 500mA, we rarely see a port that can actually provide 500mA. We always recommend the use of powered hubs or a power pack instead of relying on the USB power. Use a powered hub from a known brand, not a cheap hub. If your device has the option of using a power pack (for example the USB Client DP Module) then you can use a power pack instead. 9V 1A is typically recommended but check the bottom of the circuit board for printed voltage range. All power connectors on GHI products are 2.1mm with positive on the inside and negative on the outer ring.

Not using a powered hub or power pack can cause:
[ul]Unexplained behavior
Device does not function
Device functions intermittently
Device functions but network fails
Device functions but SD card fails
Device functions but firmware update fails[/ul]
(Generated by QuickReply)


#4

Have read that in previous answers. I have powered USB3, tried once, will retry (noting that USB3 is another potential issue).

On the USB2 bus from the M/B, I have complimented it directly with a 12V/2A supply (the one that powers the hub), same result (fez spider board rated at 7-30V). I have a drawer full of 9/12V supplies and I will try a few more. I think it’s going to come down to the PC (which I have a few more to try).

A firmware update from SD card option would be good. Divorces the update procedure from the host machine (akin to how Contour HD cameras updates, and I’m sure many other devices). Granted I’m probably in the minority, I don’t have an old crappy PC and there is nothing exotic about my setup, but I will keep swapping parts until something clicks. My current working theory is that my M/B has no serial/parallel ports (just USB+sound+etc). On the surface, not directly related, but identifying anything right now. There might be some assumption in the drivers about existing ports (long shot, but I’ve hit stranger bugs in my travels). Might be the USB chipset on the M/B.

I have two spiders now, so I can at least rule out faulty hardware to some level of confidence.

Worst case, I can live with 4.1. I don’t use the designer anyway, but would prefer the bug fixes and new features that invariably come with new versions.


#5

I tried it with 12V/1A PSU and nothing changed.


#6

Please continue using 4.1 till next release is out in few days. Then let us know if it helped or not.


#7

I have moved everything from Win7 64bit and USB3 to Win7 32bit and USB2. This partially improved things - I followed steps in updater and after setting switches and restarting, fez spider was detected on com7. So I did press continue and this is what happend:

Connecting to the device…
FEZ Spider found at Port#: COM7
GHI Bootloader Version: 1.02

Device will be updated automatically! DO NOT disconnect or turn off the device!
Erasing…
Erase successful!
Updating TinyBooter. Please wait…
Update successful!
Disconnecting COM7
Rebooting…

After reboot windows fail to install driver and after 5 second updater displays message Updating failed! Please click Start Over to restart. I restarted 3 or 4 times with same bad result. Windows see spider after the reboot as “EMX” with no driver available :frowning:

Any idea?


#8

Last SDK used a different USB driver. Please look under device manager to see if drivers are loaded and if not then direct windows to the USB drivers inside the SDK.


#9

Thanks Gus. This helped on 32 bit windows. I have now updated spider. However, whatever I tried, did not work on Win7 x64 and USB3, so I think there must be some problem with 64 bit drivers or USB3, because with the switches on windows do not recognize the device. Updating ‘EMX’ with drivers to MF debug interface was successful on both systems.

Anyway, I think people who get spider now will not able to use it with 4.1, becauce GHI gadgeteer package previously present in 4.1 package is no more available, now there is just .net mf runtime, nothing else. That’s why it is missing in VS designer in 4.1 projects.


#10

It is possible. We had ordered few more USB3 hubs and new machines with USB3 already, that we should have in few days. We will be able to do more testing.


#11

This thread will long be buried but I finally summoned the patience to try again with the latest and greatest installers since I had to fresh install Windows 7 x64.

Anyway, failed (USB2). Tried it on the Windows XP. Some mucking around with permissions and installer failures (step 5+6 failed). I manually installed the USB drivers after the step-by-step setup failed but in the end of my suffering, it worked.

So, bottom line, update on something other that Win 7x64 (eg, WinXP) and but back to Win7 x64 to develop, which works (it’s the switching to debug interface for the firmware update that fails). So, it might be Win7 x64 or it might be newer hardware that you normally stick Win 7 x64 on, since my XP box is pretty old (about 3-4 years).

FINALLY, I can code against 4.2 without wanting to throw it across the room :slight_smile: