Main Site Documentation

Firmware update on Panda II


#1

I’m attempting to update the firmware on my Panda II, and I’m following the instructions in the tutorial (http://www.tinyclr.com/downloads/FEZ_Tutorial.pdf). When I put the device in bootloader mode, however, I cannot get the drivers to load.

If I attempt to choose the driver manually (“Have Disk” etc…), I get a message that tells me the selected driver is not compatible with my device, and that if the folder contains a driver I should ensure that it is designed to work with x64 systems

Is it possible that the bootloader driver only works with 32-bit versions of Windows?


#2

What driver did you select? There is 2 of them, one for debugging and one for loader.


#3

I picked the driver from:

C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface

#4

Yes this is it, it is tested on 32-bit and 64-bit as well. My machine is 64bit


#5

Does windows ask you for drivers or not? If not then you are not in the loader more. Press and hold LDR and keep holding while you reset the board

Have you seen this http://www.youtube.com/watch?v=a3N0nQRWb08


#6

Am I putting the device into bootloader mode correctly? I’m holding the LDR button and pressing the RST button. This disconnects the debugging device, and a new “Unknown Device” shows up. It is this device which I’m attempting to load the drivers for. Is it possible that the driver is somehow incompatible with Windows 7?

In Device Manager, I right click the Unknown Device, and select “Update Driver Software…”. From there I select “Browse my computer for driver software”. In the box labeled "Search for driver software in this location, I have “C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface”. When I click Next I get this:


#7

Is FEZ connected directly to the PC or through a HUB? Try directly?
Also try to add power source to the board instead of relying on the USB power.


#8

Indeed I tried a USB port connected directly to the computer (the previous one was on a hub) and it worked. Thanks!

BTW, I’ve honestly never seen support as solid as GHI provides. You guys are an inspiration.


#9

:slight_smile:


#10

I have similar problem with cobra board, after holding up-select-down and press reset my computer found unknown device. And manually driver picking not resolve problem. Board connected directly to usb port.

Please, help me update firmware…


#11

What driver did you point windows to? C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.1 SDK\USB Drivers\GHI_Bootloader_Interface


#12

Yes, this driver. My problem in usb, и have updated firmware from another computer.


#13

I’ve just upgraded the firmware today on my Panda II without anyproblem, I’m a perfect newbie and I just followed this : http://wiki.tinyclr.com/index.php?title=Firmware_Update_USBizi .
my laptop is on XP 3 and now I can go to discover C#. :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue:

Thanks you


#14

Glad it worked fro you and welcome to the community.