Firmware installation on G80TH

I have the G80TH and I am trying to reinstall the firmware with no success. Below are the steps I have taken.

  1. Connected PE3 = LDR0 to Ground
  2. Connected PE4 = LDR1 to Ground
  3. Start Fez - Firmware Updater - Next
  4. Connect Reset to Ground
  5. Disconnect Reset
  6. Disconnect PE3 & PE4 from Ground

I have looked in the device manager and the drop down list “Select a Port” and I don’t see a serial port. Do you know what I am doing wrong?

How did you power up your board?


Thanks for the reply. The circuit I used is below. I also used 2 10uF 50V Electrolytic Capacitors on the ground and Vout.

If you power up the board and do not do anything else beside connecting the usb cable you should see something under device manager. If you don’t, the board is not powered properly.

I see G80 in the device manager. I have been successful in getting applications to run on the G80TH.

See the image below this is what I am not seeing.

If you see G80 in Device Manager still (and by the way, a screen shot of what you DO see would have been 1009% better than a screenshot of what you don’t see, which is just a static dialog in Fez Config we’ve probably all seen) then you haven’t correctly set LDR pins.

So do it all again and take a screenshot of Device Manager. What I expect you to see is initially G80 will appear, then you’ll do the LDR pins, then you’ll hit RESET. At that point you’ll get the device disconnect/reconnect noise and you’ll see a new device in the COM port section. If you don’t hear the disconnect noise, RESET didn’t work. If it comes up as G80 again, you didn’t do one or both LDR pins right.

Thanks for all your help,

I must have a board that does function properly. I have tried more that a dozen times. The G80TH screen shot shows the pins that connect to the bread board. The next two are the before connecting the LDR0 and LDR1 and after doing the reset and disconnecting the pins.

You didn’t talk about whether the device connect/disconnect noises matched up to what you expected? This is a really great way to confirm RESET has occurred properly - that way we know it’s LDR pin we need to focus on, not RESET.

PE3 and PE4 are the pins you need. On a G80TH they are pins 7 and 8 from the end - so your wiring diagram looks correct. And it looks like RESET is correct too, it’s the 4th wire from the end. From what I can see in the G80 datasheet, you actually only need to hold LDR0 to GND (LDR1 “reserved for future use”). You also don’t need to hurry to disconnect the LDR0 from GND straight away, but it shouldn’t make a difference if it comes up in bootloader mode (what we are trying to get it into). I’d ordinarily suggest using pull-up resistors (using a 10k resistor to 3v3) on both RESET and LDR0, and have them bridged to GND by a switch or a jumper when you need - since we can’t see the breadboard, how have you done that?

I think this must be related to wiring. The bootloader is a basic function so I can’t imagine that there’s anything device specific that would not allow this to work, except wiring. I’m sure we can sort this out too, it’ll just take a bit more time.

Also, just wanted to ask if this device is still in the failed state from your Ethernet work you were doing some time ago, or had you already done the LDR0/reset to get into bootloader mode and clear out your application?


The reset worked as expected with the same sound I hear when connecting the G80TH. I was able to get the G80TH to work after clearing the Ethernet application. I have got other applications to work. I just wrote this small VB application just to test the pins.

Option Explicit On
Option Strict On

Imports Microsoft.SPOT
Imports Microsoft.SPOT.Hardware
Imports GHI.Pins
Imports System.Threading

Namespace MFConsoleApplication3

Public Module Module1
    Public LDR0 As OutputPort = New OutputPort(GHI.Pins.G80.Gpio.PE3, True)
    Public LDR1 As OutputPort = New OutputPort(GHI.Pins.G80.Gpio.PE4, True)
    Sub Main()


        While True
        End While
    End Sub

End Module

End Namespace

When I connect PE4 to my voltage meter it shows 3.3 volts. When I connect PE3 my volt meter does not requester any voltage.

so when you connect LDR0 to GND, are you showing on the multimeter a 0.0v or not-connected? Perhaps you can use continuity checker to test that. It just seems like you are not holding LDR0 to GND. Especially since you did this process before!

You shouldn’t really use LDR pins as outputs - so your test app isn’t really anything I’d be concerned about. There probably won’t be a problem, but honestly I’d just not be bothering with those pins unless you’re very short of pins to use.

So fundamental question again. Please confirm you DID use this process to clear the Ethernet problem you previously had? If not, how did you clear the app?

Thanks again for all your help. I must have had a cold solder joint. I re-soldered PE3 and I was able to install new firmware without issue.
I was able to remove the Ethernet software by continually resetting the board while trying to install a new application. I re-soldered all the pins and I will try resolving the issues with the Ethernet device soon.

Thanks again,

David Weaver

1 Like

fantastic news!