Main Site Documentation

FEZHydra Bootloader v2.0.4.bin


#1

Has anyone succeeded to install FEZHydra Bootloader v2.0.4.bin and what is the correct procedure to do that? I have two brand new FEZ hydra boards with the small button to get it easier in the COM mode. My laptop has Win 10 OS. There is nothing wrong with the boards, since I have succeeded to upgrade to .netmf 4.3 loader repeatedly, after I have managed to fail with the new bootloader.
I followed the instructions from
https://old.ghielectronics.com/docs/39/fez-hydra-developers-guide :
"Navigate to: C:\Program Files (x86)\GHI Electronics\GHI NETMF v4.3 SDK\Firmwares\FEZ Hydra\Loader. Right click on Update.bat, click Run As Administrator, and follow the instructions."
I have replaced the old loader.bin with the FEZHydra Bootloader v2.0.4.bin (which I have renamed to loader.bin). It seemed that everything went well and I get the report that the process is finished, but I can’t see the new device in the device manager. Actually, nothing happens when I reset the board or plug out and plug in the USB cable.
After that, I have managed to upload back the old loader and the .netmf 4.3 firmware.
Am I missing something? I think the page
http://docs.ghielectronics.com/hardware/loaders/ghi_bootloader.html
should be improved.
Thanks in advance.


#2

You should follow the steps on http://docs.ghielectronics.com/hardware/loaders/samba_bootloader.html to get the Hydra bootloader loaded, not the docs on the old site.


#3

Thank for the advice. I have tried it before, but, since I was not sure what to use, I tried it again making all possible combinations. I have tried SAM-BA v.2.18 on Win10 and win7.
I have chosen at91sam9rl64-ek board and (now it starts to be interesting)

  • in the very first time: "Bossa Program Port (COM 6)
    … NOTHING HAPPENED after clicking Connect button
    I have waited at least 15 minutes, without success.
    The same is done with admin privileges on both Win7 and Win10
    Than I found this on the net:
    http://www.at91.com/viewtopic.php?t=23957
    The guy had the same problem with Sam9 - based board, but not FEZ Hydra
    I have also succeed to reinstall driver and I have got: “AT91 USB to Serial Converter (COMx)”, but
    unfortunately, agian, the same problem I could not connect SAM-BA to the board.
    The last thing I have tried is to change the the port speed to 115200, but without success.
    I am still missing something. Please Help

#4

Is there another computer you can try?


#5

Thanks again.
I have already tried it on Dell Inspiron Win10 and Dell Latitude Win7. I am afraid that this is not so simple. There is a catch somewhere. It will be nice that you can confirm that it worked for you and write a detailed step by step description.
Somebody wrote on the forum about Bootloader upgrade on Raptor and if I remember correct, he said that it did not work via SAM-BA GUI, but did work via command line. It means that it will be enough with command description.


#6

I have confirmed that FEZ Hydra bootloader update works with the steps outlined on docs. Previous guidance around the G400 or Hydra update for NETMF isn’t necessarily true anymore.

http://docs.ghielectronics.com/hardware/legacy_products/gadgeteer/fez_hydra.html
http://docs.ghielectronics.com/hardware/loaders/samba_bootloader.html

  • Connect a USB-Client EDP or DP to socket 2 on the FEZ Hydra
  • Hold down the small button labelled S1 near the processor then plug USB into the USB client module
  • Wait five seconds then release the button
  • If this is the first time connecting to a PC, it may take a few moments for the driver to install
  • Open the Device Manager and verify a new entry under Ports (COM & LPT). It commonly shows up as Bossa Program Port or GPS Detect, though it may have a different name. If you’re not sure, note which COM ports are present before connecting the Hydra and compare it with what appears after connecting it.
  • Open the 2.18 Samba program
  • In the first box, connection, make sure the COM port is selected. If there is an option with \USBserial\ before the COM port, like \USBserial\COM5, select that one instead of COM5.
  • In the second box, board, select at91sam9rl64-ek
  • Click connect and continue from step 3 in the above SAMBA doc. You may get a warning that external RAM access is required. Continue anyway.

#7

Thanks a lot. I have done it in the similar way before and I have got similar error message. I have even made a .bat file in order to work around this problem, but without success. Here is log from the last try:
I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA 2.18 on : windows
-I- current connection is \USBserial\COM6, \USBserial\COM6 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \USBserial\COM6
-I- argv 1 : at91sam9rl64-ek
-I- argv 2 : Bootloader.tcl
-I- Connection \USBserial\COM6
-I- Connection : \USBserial\COM6 (target(comType) = 0)
-I- Board : at91sam9rl64-ek
-I- Traces Level : 4
-I- target(handle) : 94669248
-I- sourcing board description file C:/Program Files (x86)/Atmel/sam-ba_2.18/sam-ba.exe/…/tcl_lib/at91sam9rl64-ek/at91sam9rl64-ek.tcl
Read device Chip ID at 0xFFFFF240 — get 0x019b03a0
-I- Found chip : at91sam9rl64 (Chip ID : 0x019b03a0)
-I- Loading applet applet-lowlevelinit-at91sam9rl64.bin at address 0x300000
-I- Memory Size : 0x0 bytes
-I- Buffer address : 0x4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- Low level initialized
-I- External RAM Settings : extRamVdd=1, extRamType=0, extRamDataBusWidth=32, extDDRamModel=0
-I- Loading applet applet-extram-at91sam9rl64.bin at address 0x300000
-E- Error during external RAM initialization.
-E- External RAM access is required to run applets.
-E- Connection abort

Usually, when I use SAM-BA v.2.18 GUI, it hungs when I press the “Connect” button.
I will try again and follow your procedure.
Thanks again.


#8

SOLVED
After installing Boootloader, I managed to install the newest FW



#9

Great job! Thanks a lot!


#10

Happy to hear you got it working!