FezConfig and Windows 10

We have been using FezConfig (v1.0.1.0) successfully for years to install Firmware and our application. In August our shop went 100% Windows 10 and for the first time we are programming new G400 boards and experiencing a 100% failure in FezConfig on multiple Windows 10 PC’s.

When we go to program the firmware, it connects to the device ok, then proceeds to updating the firmware, and then within 4-5 seconds it errors out with a “Interrupt while deploying. Updating failed!” message.

We originally thought this might be because new boards were coming to us with Tinybooter and we were used to Tinybooter. After some troubleshooting I became suspicious of the Windows 10 and spun up a new Windows 7 machine, installed all the tools and was able to program G400’s with Tinybooter and with no issues at all.

Any advice or help is appreciated!

Adding in a screenshot of the error

Also, ran a ProcMon session to see if anything popped out. The only thing that I can report out of that is I see config.hex and firmware.hex being read completely.

can you try (FezConfig run as Administrator)

another left(ish) field here. Can you confirm you rebuilt one of your usual PCs that were failing with Win10 and used Win7 on it? Thinking that USB differences might be affecting this - the USB timeout on different hardwares?

Were you doing a rebuild to Win10 or an upgrade?

I tried FEZConfig right-click, Run as Administrator and had the same result - Interrupt while deploying. Updating failed.

We had a Win7 PC working for years that PC was upgraded to Win10 and FEZConfig stopped working on it.

I did try plugging the USB into a port on the back of the PC this morning to see if those were of a different HW nature, but had the same failed result.

You might try a Virtual Win7 machine?

just to be clear - was it an in-place upgrade or was it a flatten-and-rebuild?

The Win7 to Win10 upgrade was in-place, performed by our IT department.

I was kinda hoping it was not an in-place upgrade and that we’d find something was “missing” when Win10 was rebuilt…

But in that case, I am struggling to point out anything “big” that would make sense here. GHI may know their codebase and might be able to advise what external dependencies they have, and you can check that there’s not something missing. Have you tried to reinstall FezConfig again?

What about non-G400 devices, do you use any of those and if so have you tested on them ? The G400 is one of the few devices that uses the SAM-BA software - in fact, now I start thinking that, I reckon I had issues installing SAM-BA onto my new Win10 machine when I got it, and the original version that GHI put alongside the FezConfig wasn’t compatible and I had to manually grab a current version to install. I have SAM-BA 2.18 installed but don’t have a G400 close by to check I can program it. That would be worth a go I reckon!

It works for us and many other customers so I am not sure why.

We are using Win 10 1903 and G400-S. No problem for us too. Sam-ba is not installed. Deploying via FezConfig / MFDeploy / VS 2015 never failed.

1 Like