Main Site Documentation

FEZconfig and VS2012 does not see G120 module


#1

Strange problem. I got everything woriking with my G120 based board just two days ago. Two days fast forward and VS2012 does not recognize as target device. FEZconfig does not recognize it also. In device manager I see “GHI NETMF Debug Interface” comming and going. I did nothing unusual, just turn of/on computer and it stopped working. Any ideas?


#2

Also if the device reboots all the time you would see this behaviour.
This can happen if your program on the device crashs just at Startup.


#3

Thank You for reply.
Well maybe I should clarify that “comming and going” appears then I intentionally plug and unplug usb cable. So I really doubt that it is power supply related. And as I wrote everything was working two days.


#4

Well It passes startup. It goes into previuos program. But good guess, since I did modifications to startup process (added lcd startup logo).


#5

Are you able to get it working again if you follow the manual update steps located here:

https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families#521


#6

usually a good way to get startup problems resolved is as James points out, manually erasing either your application if you can get MFDeploy to work (you probably won’t be able to do it in time) or to reapply the firmware by manually going into the bootloader mode.


#7

Finally I got back to this issue. I did one trick: tried on collegues PC who also works with GHI stuff. And Visual Studio recognised device, so it is totally not device bootloader fault. Drivers are most likely to blame. Tried to install all packages to my laptop and device is also recognised. Tried to uninstall everything GHI related from my PC and still no luck, so what steps are required to clean GHI drivers completely from my PC and reinstall them again?


#8

@ jb.lightcon

Just go to the control panel and uninstall the GHI stuff and then re run the SDK installer. With the new installer, you can be selective of what you uninstall and re install.