Main Site Documentation

FEZ Spider with blinky app bug


#1

If I create a blinky app (with motherboard led) for FEZ Spider with TinyClr 0.6.0, it runs fine without debugger.
If I launch it with debugger and stop debugger, after a while (1-2 mins) application may crash as no led is more blinking.

Here code used:

    class Program
    {
        private static GpioPin _led;
        static void Main()
        {
            string deviceName = DeviceInformation.DeviceName;
            Debug.WriteLine(deviceName);
            Debug.WriteLine(DeviceInformation.Version.ToString());
            if (deviceName == "G80")
                _led = GpioController.GetDefault().OpenPin(GHIElectronics.TinyCLR.Pins.FEZPandaIII.GpioPin.Led1);
            else if (deviceName == "netduino3")
                _led = GpioController.GetDefault().OpenPin(GHIElectronics.TinyCLR.Pins.Netduino3.GpioPin.Led);
            else if (deviceName == "EMX")
                _led = GpioController.GetDefault().OpenPin(GHIElectronics.TinyCLR.Pins.EMX.GpioPin.P1_31);
            else
            {
                return;
            }
            _led.SetDriveMode(GpioPinDriveMode.Output);

            while (true)
            {
                _led.Write(GpioPinValue.High);
                Thread.Sleep(200);
                _led.Write(GpioPinValue.Low);
                Thread.Sleep(500);
            }
        }
    }

#2

Can you ping?


#3

I am seeing the same behavior with USBizi. Let me try a ping.


#4

Using TinyCLR Config -> Ping, I get Status as “Pinged”

LED stops blink

    {
        GpioPin led = GpioController.GetDefault().OpenPin(
        GHIElectronics.TinyCLR.Pins.USBizi100.GpioPin.P0_16);
        led.SetDriveMode(GpioPinDriveMode.Output);

        while (true)
        {
            led.Write(GpioPinValue.High);
            Thread.Sleep(100);
            led.Write(GpioPinValue.Low);
            Thread.Sleep(100);
        }

    }

#5

All NXP decided share the same core so a similar behavior makes sense. I am guessing we have a timer issue, not a device crashing.


#6

I can ping it too, and what @Designer says is reassuring: it can be reproduced !


#7

This may be the same known issue that we found for the USBizi. We will look into it more with EMX as well.


#8

Could not reproduce after 0.9.0


#9

Good news ! :sunglasses: