Main Site Documentation

FEZ Spider Waiting for debug commands


#1

none of the solutions I found on the forum worked.

On boot, I see
EMX
Version 4.2.7.0
Debug: USB1
LCD: 320x240
Waiting for debug commands…

I have used the updater and it finished with no messages.

Project is set to .NET Micro Framework 4.2

Any ideas?


#2

The driver is
c:\Windows\System32\drivers\GHI_NETMF_Interface.sys


#3

[quote]
none of the solutions I found on the forum worked.[/quote]

For what problem?

What problem of the SDK is loaded on your PC?


#4

Solutions for “Waiting for debug commands…”


#5

Ah. Means there is not an application on the device. Deploy a project and it will go away.


#6

I can deploy a solution to the device, and VC# says is completed successfully.

However, the FEZ Spider does nothing, just displays the messages I posted in the first post.

I have a button and a T35 display connected.

I went back to using the “button” example to get to a simple application


#7

Incrementally deploying assemblies to device
Deploying assemblies for a total size of 233456 bytes
Assemblies successfully deployed to device.


#8

Tom, is it possible that you have a SDK and firmware mismatch? Please check the release notes from the GHI SDK install location (c:\program files(x86)\etc etc) and see what version of firmware is expected. Even then, I would suggest you go through the firmware update process to ensure you have everything matching, because that seems unlike any other issue we’ve seen.

(you don’t happen to have a second Fez device attached do you? that’s about the only other thing I can think of!)


#9

EMX v4.2.7.0, TinyBooter v4.2.7.0
G120 v4.2.7.0, TinyBooter v4.2.7.0
GHI Premium NETMF Library v4.2.7.0

Just to be safe, I downloaded and reinstalled.

Same problem


#10

please post the contents of the output window after deployment

this will also occur if you let your main function exit.