Main Site Documentation

FEZ Spider Unresponsive - no USB connectivity in Default mode


#1

My FEZ board I’ve been successfully using for a while has suddenly stopped. After reading the details below, can anyone help confirm my suspicion that its dead? Or suggest any CPR maneuvers to resurrect it? :slight_smile: Also, is there a warranty on these?

Device: FEZ Spider
OS: Win 8 (also tried Win 7 on another PC)

What I tried:
[ol]Plug into PC, no response from PC. No driver loaded. Power light on Spider is on.
Plug Cerberus into same PC (same cable, same USB Client DP Module) - works fine. Driver loads, device is seen.
Plug Spider into another PC (Win 7). Same issue, no driver load.
While device is plugged into PC, press reset button on Spider. Still nothing.[/ol]

Also note: I can get the device to be recognized by the PC in Loader and TinyLoader mode, but not Default mode (switch 1,2 & 3 off, switch 4 on, right?).

I can’t really do much if the device cannot even be seen on the PC. Am I screwed?


#2

@ neoscoob - Sometimes if your program crashes soon after starting, the device becomes unresponsive. You can try to erase the program using MFDeploy. Worse case, reload the firmware, which will erase the errant application.

While the Spider has ROHS certification, mouth to mouth resuscitation is not recommended.

Not as far as the Spider. Very few people are capable of killing a Spider.


#3

try this https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting


#4

LOL. Mike, that was a great response.

Indeed, the spider has yet to be killed. :slight_smile: What I ended up having to do is go back to the LEGACY updaters and redo the EMX loader, Tiny Bootloader, firmware, everything.

RESOLVED.


#5

By legacy, which version do you mean? 4.1?


#6

Ian, by Legacy, I mean rather than the FEZ Config app, I downloaded the “Legacy versions of our firmware updaters” zip in step 4 here:
https://www.ghielectronics.com/support/.net-micro-framework

And I followed the steps shown here:
https://www.ghielectronics.com/docs/54/firmware-update-emx

I did not try FEZ Config, and I doubt it would have worked because it seems to require newer loaders to even talk (see this post: https://www.ghielectronics.com/community/forum/topic?id=12036&page=6#msg129895, especially comments 56 and 57)

My spider loaders/firmware was way old (original from over 1 yr ago) because I was using v4.1 before. Now I’m on a clean new PC with v4.2 and the spider would not even attempt to load as a USB device (not even as an unknown device) unless I switched it into Loader or TinyLoader mode, at which point I use the “legacy” updaters. After that, I switched all 4 switches off, and the Spider is working as expected when connected to PC.


#7

@ dapug - Thanks. I’m having a very similar problem with my Hydras. I’ll give this a try tonight but I think my problem may be different than yours now.