FEZ Spider Starter Kit Issues

Hi guys!

First I want to say that this is a great community and I am really excited to be part of it and I really hope that I will find some assistance here!

I’ve just purchased the FEZ Spider Starter Kit and have been struggling with updating its firmware. I moved through all the USB connection issues that have been discussed here and managed to solve them by buying a USB Hub which I am using to connect the mainboard to my PC. Finally I seem to have successfully updated the firmware but now I can’t get any Visual Studio app correctly deployed on my device. All of the configuration switches on the mainboard (the little white ones) are set to default but my PC cannot at all detect the device as connected. Moreover, on the LCD of the device I am getting the following:

ABORT Prefetch

Build date:
Aug 22 2012


This appears shortly after I see the default firmware version info and the LCD screen size. I guess this is not expected.
Any help will be appreciated!

This message should never appear. It is the BSoD for spider!

Make sure you have a reliable power source. Powers hub is always recommended.
Make sure you have tinybooter and tinyclr from same SDK. If you used the firmware updater them this is done automatically.
Are you using 4.1 or 4.2?
Have you tried to run an empty project?

Welcome to the community.

Noticed you already have a powered hub.

What program, modules cause this message?

Hey Gus,

Thanks for the quick reply!

I somehow now managed to get all things running. Actually I haven’t managed to update the firmware by using the automatic updater since it’s been crashing all the time. I followed the manual routine by using the Tetra… tool and the MSDeploy. I tried doing it a couple of times. The successful one appeared to be when I chose to deploy both firmware.hex and firmware2.hex that came with the SDK. This got things running but, honestly, I now don’t remember in what sequence I did the manual deployment.

Anyway, I am now exploring the samples and playing with the camera. Will let you know if something emerges although until now I only got the BSoD only once and it came away after restart.

Greetings from Bulgaria and take care!

Thanks once again!

I’ve been asking myself is there a possibility, and if yes -any guides on how low-level programming is done by using CSHARP? I mean accessing the sockets, sending and reading bytes etc?


Gadgeteer runs on top of netmf. We have a lot of tutorials and gadgeteer is open source if you want to see how it is done.

Great. I’ll be diving into this for sure.

Anyway, some more information on why should I use both firmware.hex and firmware2.hex that came with the SDK? When using the Updater tool which files should be chosen besides config.sig and config.hex?


Sorry, missed to mention that I am using the 4.2 SDK.

All these files are part of the firmware.