Main Site Documentation

Fez Spider Starter Kit error in VS2012


#1

I have the following error when i try to build a Gadgeteer app to my Spider:
Error 1 Device not found or cannot be opened - USB:GADGETEER

I have updated firmware and such, but i think it might be a problem with the device being in the wrong mode. However, i am not the first one to work with the thing here at the office but the person who started using it is no longer around. The problem i have is that i do not have a thing showing me what the dip switches on the device actually do.

Or it might be another problem, which would be nice to get fixed :slight_smile:


#2

welcome Kayshin,

Check device manager, and then MFDeploy. In Device Manager, you should see a debuggable .net microframework device, since that’s what the Spider would normally show when it is running the framework in framework mode.

In MFDeploy, you need to change your connection method to USB, and then you should be able to see what it’s name is.

Tell us that, and the next steps may be more obvious.

One of the documents available here is the developers guide, https://www.ghielectronics.com/docs/170/fez-spider that has a link to the starter kit getting started PDF, that has a “set-up issues” section that says you may need to rename your device. Another option is to use the firmware updater tool from the “Support” link above, and update the firmware (always recommended) and it also, from memory, helps with the Spider switches (I don’t have one to be sure sorry!)

Note to GHI, maybe it’s worth putting up a PDF of the card that goes with the mainboard on the resources tab?


#3

I managed to get it working by reconnecting and reinstalling everything for the 4th time or so, and pressing the reset button a few times, i dont know what was wrong but it is working now :slight_smile:


#4

@ Brett -

For Kayshin or others


#5

Thanks a million, this could come in handy in the future :slight_smile:


#6

I’ve had this too. All I needed to do was go to the project settings and re select the emx in the .net microframework selection and save the project