Main Site Documentation

FEZ Spider not switching to loader mode


#1

Hello all,

I´m trying to update the TinyBooter on the FEZ Spider as described in this post:

https://www.ghielectronics.com/community/forum/topic?id=16491&page=1#msg163454

I have connected the Spider with the USB Client SP or the USB Client DP module without any other modules connected but no devices (nothing (no unknown device…)) is shown in the device manager. (The Spider is set to loader mode by switching the last 3 dip switches on).

I don´t think that is is a problem of the USB connection, module or cable but a problem of the Spider switching to loader mode.

I have connected a display module to look what´s going on.
After the reset I see Message1.jpg for a second (with TinyBooter Mode).
Then the Message2.jpg is shown and nothing else happens.

Changing the DIP switches don´t changes the behavior.

Is there another way to put the Spider in loader mode
(something like this for the FEZ Hydra:
https://www.ghielectronics.com/community/forum/topic?id=16269&page=3#msg161777
) or can I do something like a factory reset or flash with SD card …

Thanks and regards,

Heiko


#2

The picture doesn’t appear to show an external power source feeding the USB_DP. Do you have one as I had problems updating my Spider until I added external power; or at the very least ensured that the USB was fed from a powered hub.

Good luck.


#3

Thanks for your fast reply.

I was able to connect to the Spider in normal mode before I used the Plug-in -> Debug -> Erase Firmware - Function of the .Net Micro Framework Deployment Tool.

Now the Spider always shows the two messages and I can´t connect anymore. The Spider is not shown in the device manager (no USB device) independent of the dip switches.

I think in normal mode the problem is the “Halting CPU” message.


#4

I have tested the USB Client DP with and without external power source but it doesn´t change anything.
Which behavior is normal for a Spider switched to loader mode. In my opinion the spider should not try to execute any managed code and so the Message "main exited???. Halting CPU should not appear. Also “EMX TinyBooter Mode …” should not be shown.

Does the connected display change the behavior of the Spider ?


#5

I hope this information helps:

https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families


#6

The connected display should not drastically alter the behavior of the device on boot up, so it’s great that you were able to see those messages.

One thing that I am not clear about is what happens when you boot in normal mode, do you still get the same error ? You said you think - can you confirm that when you power up the device in normal mode what the display shows (it should not say “tinybooter mode” as it does in your first image) and whether that error is displayed?

Those errors are unusual and not often reported, so it most likely implies something unusually weird - it might take some time to help diagnose that, I hope you are ok with that ?

Can you give us some history - how long have you had the Spider, have you used it and programmed it a lot in the past or are you new to using it as well ? Have you recently upgraded your PC or anything that you’re aware of ? Have you recently changed cables around at all, or again has that been reasonably stable ? Do you have a replacement high quality USB cable (typically this means it is thick and relatively inflexible, and preferably one with a magnetic interference recusing balun over it). Can you also take shots of Device Manager when you are running in bootloader mode and normal mode, and make sure you have sound turned on so you can hear if you hear the windows device detected noise or not.


#7

Regardless of witch mode I have configured, the messages are always the same (First: EMX TinyBooter Mode …, Second: main exited …).
The switch (USB/Serial debug) changes the debug mode from “Debug: USB1” to “Debug: COM1” but TinyBooter Mode is always shown and the output stops on “main exited. Halting CPU”.

The history:
I have bought the used “FEZ SPider starter kit” 3 weeks ago. I don´t know what the previous owner has done with the spider. The NETMF Version was 4.1 and I was able to connect with Visual Studio 2012 to the device. Because I have only installed NETMF 4.2/4.3 on my computer I wasn´t able to deploy my first program (error message because of the wrong NETMF version). The connection was OK in normal mode.
Then I tried to update the TinyBooter but regardless of the dip switches the Spider always shown as a NETMF Device (no unknown or serial bootloader device).
Then I tried some functions of the “.Net Micro Framework Deployment Tool” and I think I have overridden something on the device so know I always get the Halting CPU message and the Spyder doesn´t connect in any mode (no changes in device manager if I connect the Spider).

I have tried three different USB cables (one of them works before) and all combinations of USB Client SP / UP with external power source.

I have a RS232 module. Is it useful here (but when the device don´t switch to loader mode) ???


#8

@ Heiko.H - of the board is in serial mode, you can send a character on power up to force the GHI loader. I think it was ? So rest the board while repeatedly entering ? Symbol on a terminal software


#9

@ Heiko.H -

Try to remove all wire connected (LCD, module…)

Just keep USB Client DP or SP. That is enough for updating

and try again.


#10

I have connected the FEZ Spider with the RS232 and started Tera Term VT with Baud Rate = 115200. The Spider sometimes sends some curious characters (on power on/off, see the image) but it is not possible to control the Spider like described here:

https://www.ghielectronics.com/docs/54/loader-tinybooter-g120-and-emx-families

repeatedly entering ? on power on/reset doesn´t change this behavior

The spider is powered by the USB Client DP with only the external power source connected.


#11

I have tried all combinations but no device was shown in the device manager.


#12

if use serial mode, did you you push the switch 4# to on?