Main Site Documentation

FEZ Spider not recognized by Computer


#1

My computer shows “Unknown Device” in device manger under USB-Controller.
Device Id is USB\VID_0000&PID_0000\5&1280EE4&0&1
Problem code is 0000002B (or decimal 43).

Board boot normal. Display shows:
EMX
Version: 4.1.7.0
Debug: USB1
LCD: 320x240
TP: 192.168.1.200
MAC: 00.1A.F1.00.42.0D
Managed heap size: 13041664
Cutom heap size: 1048576

External power supply is connected.
I’ve tried everything: Other computer, Loader mode, Tinybooter mode, 2 different usb cables, all usb ports of PC and Laptop, different power supply, reinstalled software and did everything discribed under http://tinyclr.com/forum/21/4846/

Not sure what to do now.


#2

Just to double check it (in case it is a different unknown device) - try MFDeploy. Is it visible there?


#3

When I disconnect the usb cable, the unknown device will disapear. MFDeploy does not show devices.


#4

Put your jumpers on the GHI loader mode. This should load virtual serial drivers.


#5

I also tried the loader mode. It does not help. Device manager also shows unknown device in loader mode.
I addition I tried to update the driver manually from C:\Program Files\GHI Electronics\GHI NETMF USB Drivers\USB Drivers\GHI_Bootloader_Interface. Windows device manager tells me, that the driver is not compatible with the device.


#6

so going back to first principles. Has this ever worked ? Has it worked on another computer? Has there been anything else that has obviously changed if it used to work? Is this a brand new Spider? Do you have another computer that you can try the same on? Do you have another USB cable you can try?

Edit: I see the “other computer” and “2 USB cables”…


#7

The board is brend new. I think it has a defect, What I could do is to order a second board and a second USB Client DP Module and than check which one is fault.

The problem is, that I’ll again have to order in UK. I could not find a shop in germany that has FEZ spider boards on stock.

Any other ideas?


#8

OK, so I also assume you don’t have any other Fez boards that you use?


#9

Yes, it’s my first board…
It is a little bit frustrating to have problems right from the beginning :slight_smile:


#10

Do you see anything on the display?


#11

Yes! The display shows:

EMX
Version: 4.1.7.0
Debug: USB1
LCD: 320x240
TP: 192.168.1.200
MAC: 00.1A.F1.00.42.0D
Managed heap size: 13041664
Cutom heap size: 1048576

Waiting for debug commands…


#12

Last thing, post a picture showing the module connections please.


#13

Image 1


#14

Image 2


#15

Image 3


#16

Image 4


#17

All looking good! Please email me directly (gusi@ ghi domain) or call the office and let me try to step you through it.


#18

I’ll send an email.

I would like to check if the problem is caused by the USB Client DP. Is it possible to connect the USB Host Module directly to the USB Client DP, to check if USB Client DP is ok?

Like this:
Computer <-> USB cable <-> USB client DP <-> DC cable <-> USB Host Module <-> Some USB Device.

Let me know, if this will work to check the module, or if it is a stupid idea.


#19

Connect the camera to usb client and plug to your PC.


#20

When I plug in the camera as described, then I get the same error: unknown device.