Main Site Documentation

Fez Spider firmware upgrade from 4.1 to 4.2 fails


#1

Hi all :slight_smile:
I’ve just received my first board, a Fez Spider with 4.1 firmware version.
Since version 4.2 was available, and since the guide suggested to upgrade the firmware ASAP, I downloaded the 4.2 SDK and tried to upgrade, but without success.
The log of the software “FEZ Spider Mainboard Updater” is as follows:

After the reboot the device is not recognized anymore, and after a few seconds appears a windows with the following message:

[quote]Updating failed !
Please click Start Over to restart.[/quote]

I tried at least 10 times, but without success.
The board is connected through a powered USB HUB, so I strongly doubt it can be a power issue.
Does somebody have some suggestions ?
Thanks to anyone that will help :slight_smile:


#2

What do you see under device manager?

And welcome to the community.


#3

Hi and thanks for you fast reply.
While the board is configured for load, I see it as "GHI Boot Loader Interface (COM9)"
While it’ configured for normal operations (all switches off), Windows 7 doesn’t recognise it anymore (it was recognized before upgrading) and I see it under “other devices” as “EMX”.
Windows is telling that "the drivers for the device are not installed (code 28)"
Any suggestion ?
Thankyou very much.


#4

I managed to make it work.
I had to manually force a driver installation for the EMX to solve it.
Thanks anyway for your support :slight_smile:


#5

Can you share how exactly you solved the problem because we have the exact same problem.
At least if appears failed the same way.
Thanks!


#6

Please see the note here http://www.tinyclr.com/forum/topic?id=9388

Welcome to the community.


#7

I have the same problem, but manual driver setup doesn’t work.
When I use C:\Program Files\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_Interface directory, “GHI NETMF Debug Interface” is being installed, but in the end I get this message:
“An error occured during the installation of the device
A service installation section in this INF is invalid”

Any suggestions?

Thanks in advance.


#8

I just manually bound the alredy installed drivers to the unrecognized USB item in the devices view of Windows 7.
That worked fine.
Sorry I can’t help you more, but I’m a newbie on this argument


#9

I managed to do this on Windows 2008 Server. It seems the driver doesn’t work on XP.


#10

It does but you need all service pack as it uses WinUSB http://msdn.microsoft.com/en-us/library/windows/hardware/ff540196(v=vs.85).aspx


#11

I was able to install the driver. Now when I plug in the spider board, it regonize it and shows GHI NETMT Debug interface in the device manager.
But the update still fails when I used the FezSpider updater. Now that when it boots up, the display board shows :
"TinyBooter v4.2.0.0 EMX Build Date Oct 24 2012 13.43.11 Waiting"
I am stuck now. Suggestions?


#12

A little more info. Righ now when I put it in loader mode (all switches on), it fails to install the driver successfully. It recognize as GHI Bootloader (com9) but says: “This device cannot start. (Code 10)”.


#13

So if you are having a problem after updating to 4.2 with the spider…
Just check this: in windows go to devices and printers and you should see a device called EMX that isn’t installed properly.
Choose update driver on this device and browse here to find it
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_Interface
It will update the driver and then you can run the firmware update sucessfully.
Sorry to post this again but it took me two hours to work out what this post was trying to tell me to do and it is simple
Andy


#14

Hi , I am , working with Fez spider kit , there is some wrong with the update firmware to the end of the process(rebooting the board), I saw several cases
with the same problem , GHI community talk about the correct drivers in normal operation of the board and loader operation.
What is the right app to update the firmware FezSpiderMainBoardUpdater or EMX updater ?, what is the difference, between , loader and tinybooter? , How is the right configuration switch when we try to update the firmware?, in some cases GHI community talk about an external power source paralel with usb cable to avoid
problems derivated from low power , but in my case is the same response.
In both connections of the board , normal operation and loader operation the board is recognized as Com Port , but i dont know what is wrong , I am using OS XP 32b.
Is there some troubleshooting guide specifcly in this theme.
Thanks.