Main Site Documentation

Fez Spider - Cannot run VS2010 debugger


#1

Hello,
Well I feel bad to be stuck so early but I haven’t gotten anywhere.
I have a brand new Fez Spider with TE35 display. I have all the tools installed and can build an app in Visual Studio 2010.
I also upgraded my firmware successfully.
Upon booting I see some data printed in the TE35 display followed by “Waiting for Debug commands”.

I press F5 to run my app in the debugger with a breakpoint at the { in ProgramStarted(). The device gets rebooted, all messages are fine. I finally see “Device in Initialized State”.

However after I get that message, the debugger just quits - as if I hit stop, and this is before any breakpoint is ever hit.

Has anyone seen this before? Kinda frustrating. My app builds fine and attempts to run. VS even reboots the device and says Deployment Successful!

EMX version 4.2.4.0.

Hopefully someone has seen this behavior and knows what’s up.
Thank you in advance for any info to get me past this!


#2

“Waiting for debug commands” usually means your firmware and framework versions don’t match. But you said you successfully updated the firmware. Can you use FezConfig and show us the check it does to confirm? And can you then show us the code you’re trying to deploy (or talk us through what you build in the Designer and programstarted)?

I always try to step back to the simplest scenario when I get weird stuff happening. Does a “LED Blink” app deploy the same and with the same results ? If I use MFDeploy to attach after VS has “detached”, can I see debug messages?

Can I also ask, why VS2010 and not 2012?


#3

and why 4.2.4.0 ?? The latest is 4.2.11.2


#4

Hi Brett,

I had to do some digging to see what link to take to have the latest GHI installs to use. I somehow found 4.2.4.0!

I think starting from scratch would be ideal based on what you said I am seeing. In fact, I didn’t even use FezConfig, I couldn’t find such a program in my Programs list! That too points to the fact I must not have the right stuff.

The only compilers I have are VS2010 and VS2013. VS2010 works great for my Cerberus projects, never had an issue with it.

Can you tell me the proper link or links where I can get the libraries, firmware, and tools? I will then do installs all over again and see if the problem persists. Googling this just turns up too many possibilities and clearly I’ve got a mish mash that’s not working.

Thanks so much for your help!


#5

go to the “Support” menu option above, then netmf. You end up at https://www.ghielectronics.com/support/netmf

From there, there’s a link to VS2012 and the correct support packages, including VS2012, the netmf SDK package you need, and the GHI SDK - as well as links to the reference material.


#6

Ok I downloaded and installed all the newest stuff.
FEZConfig connected to the device and reported the new version and the old version on the device correctly.
I went to the updater selection menu. All was going fine ten out of nowhere - Updated Interrupted!
At this point I cannot connect to the board any longer as the updater wiped everything out.
I was surprised I was not told to set the DIP switches for update - should I have done that and if so is that the reason that the updater failed?

What’s the best way to get this Spider updated now that I’m in this state? At least I know I have all the latest stuff, once I can update the device I ought to be golden.

Thanks Brett for all your help today and if applicable - Happy Father’s Day :slight_smile:


#7

Ok I reloaded everything on the Spider, created a new app in VS and built, then deployed and all is in sync and debugger doesn’t quit :slight_smile:

Now I will slowly bring my code into this “new” solution. Everything seems to be behaving nicely now.

Thank you Brett for the assist otherwise I’d not be at this point. The problem was exactly as you said - firmware and framework mismatch totally.


#8

great to hear you’re a happy camper !

FezConfig is smart enough to make the device switch into bootloader mode when it needs, without manual switching. Cool huh !

In Australia, we for some reason celebrate Fathers Day as the first Sunday in September. Must have been set that way by a greeting card company to try to level out the global demand for those specific cards :slight_smile: (but anyway, I have no kids so not applicable :slight_smile: )