Main Site Documentation

FEZ Spider Board is Very Slow


#1

I have a FEZ Spider, to which, I have connected an SD Card module, a T43 display and a WiFi RS21 board. I have installed NETMF and Gadgeteer Package 2014 R5.

When the system starts, I first wait for a SD card mounted event. The “Mounted” event is raised after about 40 seconds, consistently. I do not think this is expected. Can someone confirm.

The next problem is that I have made a window and I have a single button with tap event. When I open the window and click on the button nothing happens. The system is unresponsive. After about 30-60 seconds of wait, when I click the button again, it works normally.

It seems, that everything takes a long time to initialize. Any idea why?


#2

To add more, I’m using the Glide library.
I first open Window1, then in a separate thread, wait for 5 secs and trigger the close event.
In close event of Window1, I open another window Window2, then in a separate thread, wait for 5 secs and trigger the close event. In the close event of Window2, I open this window, Window3 that has the button.

Hope it helps.


#3

I can’t help you but I would suspect to be really helpful you’ll need to give a few specific details of your setup.

  1. what SD card are you using, and have you tried multiple cards? Do they all perform the same ?

  2. what firmware do you have - paste the check text that FezConfig provides.

  3. prove that these two aren’t affecting each other - have JUST the SD card code in place and test, then have JUST the Glide code and test. Share with us the simple tests and findings as that’s more likely something that someone else can test and compare.

None of this sounds “normal”, but I can imagine how application code could be made to make the system behave like this.


#4

@ Brett Thank you for helping.

The firmware text is pasted below:

Loader (TinyBooter) version information:
4.3.4.0 on this computer.
4.3.4.0 on this device.

The Loader (TinyBooter) is up to date. <<<

Firmware (TinyCLR) version information:
4.3.6.0 on this computer.
4.3.6.0 on this device.

The Firmware (TinyCLR) is up to date. <<<
Please wait for the device to reboot… Done.
========================

I have a SanDisk , class 2 , 2 GB SD card. I have not tested with other SD cards. Let me buy a new one (perhaps a class 6 or a class 10) and try again.

Let me change my code to first test only with the SD card and then separately with the Glide window and I will share the results.


#5

certainly suggest you look at alternate cards, some of them can behave strangely…

Splitting your code into manageable chunks for this test and into their own project will help you and help anyone here because you can show the code as-is and not need to expose unnecessary parts.


#6

@ Brett Thank you for the direction. I managed to solve this. If we ever meet, the lunch is on me :slight_smile:

Before you pointed out, I had looked everywhere, but not the SD card.
I tried with different SD cards and here are the results:

  1. 2 GB Class 2 SD card => Mouting takes about 40 seconds and the entire system is unresponsive. Not usable at all

  2. 4 GB Class 6 SD card => Mouting happens in about 5 seconds and system performance is very close to not acceptable

  3. 16 GB Class 10 SD card => Mounting happens in under 1 second and system performance is fine. No issues.

Thus, it was the SD card. I found the right performance with a 16 GB, class 10 SD card. In general, I guess class 10 SD cards should work, but I did not want to spend any more money to test on more types.

Thank you once again Brett.