FEZ Reaper Power-Up Issue

To start I’d like to say I’ve really enjoyed working with GHI stuff.

So, I’ve been creating a network of GHI based controllers. In that network are 5 FEZ Reaper boards with the exact same hardware setup. Three of them work like a charm but two of them stall when they are powered up. In order for them to operate the reset pin must be pushed. This started right out of the box. I was not able to program them until I pushed the reset button.

To make sure it wasn’t one of the peripherals plugged into the Gadgeteer sockets I pulled all of them off with the same result. The reset pin has to be pushed after they are powered before they will operate.

To make sure this was not a power supply issue I tried using both the USB Client SP Module [url]https://www.ghielectronics.com/catalog/product/330product/330[/url] and the USB Client EDP Module [url]https://www.ghielectronics.com/catalog/product/525[/url] as the power source. In either case I supply plenty of power to the modules and the three other Reapers work just fine with the configuration. So, I don’t think it’s a supply issue.

My controllers need to be able to run on power-up without intervention.

Any ideas?

Thank you!

Thank you. I am happy to be a part of the community. :slight_smile:

Yes, the first thing I did was update the firmware using FEZ Config. It came with 4.3.9 and I updated it to 4.3.10. I updated the other three units at the same time. These two units were the only ones that required a reset button press to get FEZ Config to connect.

We will test a few on our end. Are you in the U.S.in case we need these for further testing?

Did you update both the TinyBooter (bootloader) and the firmware?

Are you in the U.S.in case we need these for further testing?[/quote]
Yes, I am on the east coast.

Did you update both the TinyBooter (bootloader) and the firmware?[/quote]
I believe I did. Using FEZ Config I clicked on Advanced>Loader (TinyBooter) Update>G80 (FEZ Panda III). Then I followed the process that looks identical to upgrading the firmware. I did not see any indication of the boot loader actually being updated. Was that correct? I expected to see some sort of indication that the boot loader was updated.

@ ianlee74:
An additional note. Here is what I find in the FEZ Config About dialog box.

[quote]NETMF v4.3:
EMX: Firmware, Loader
G30: Firmware
G80: Firmware
G120: Firmware, Loader
G400: Firmware, Loader
Cerb-Family: Firmware, Loader
FEZ Hydra: Firmware, Loader[/quote]
I noticed that the G80 does not have a loader identified with it. I wonder if that matters when I try to update the loader.

Ok, when I do that this is what I get:

[quote] Firmware (TinyCLR) version information: on this computer. on this device.

The Firmware (TinyCLR) is up to date. <<<
Please wait for the device to reboot… Done.[/quote]

And it still hangs on power-up.

Thank you so much for the help… I’m impressed by the prompt replies!

@ Hawkez - As a test, can you connect pin 4 on socket 6 of the FEZ Reaper to ground and then power the board and see if the issues goes away?

@ John - I connected pin 4 to pin 10 both on socket 6 with no change in results. A press of the reset button was still required before it would run.

@ Hawkez - What if you connect to ground, add power, then connect the pin to 3.3V?

@ John - I connected pin 4 to ground (pin 10) and powered the board on. Then I moved the connection from ground to 3.3 (pin 1). There was no change in results.

@ Hawkez - Last test, if you connect it to 3.3V then power the board, any change? If not, since we are not able to reproduce it here, we’d have to see your boards.

@ John - They don’t want to play. :frowning: How should we handle this?

@ Hawkez - If you can send the boards back to us, email support@ ghi… for an RMA with a reference to this thread. We will take a look to figure out why the do not want to power on.

@ John - Ok, I emailed support@ ghielectronics.com on Friday but have not heard anything back. I looked in my spam folder and still nothing. Can you check on this?


@ Hawkez - We’re sorry about that, you should have a reply now.

@ John - Wow, that was fast! Yes, I got a reply. Thank you.

@ John - Hey, is there an update to this issue?


@ Hawkez - Yes, on your two boards, a resistor was damaged that was required for the board to boot properly.

1 Like