Fez raptor stuck in boot loader mode


I have two fez raptors that I have stuck in bootloader mode. Both of them say disconnected in fez config and mfdeploy. tried running update.bat from the ghielectronics g400S folder and it says no device connected or not responding. My question is how do you get them out of bootloader mode and update firmware again. I've tried different client dp modules tried just on usb 2.0 instead of 3.0 tried different cables tried powering the board through dp module. I'm running windows 10. could someone please help me. Even tried different computers running windows 10.

One doesn’t show up at all and the other shows as boss’s com11 neither one is recognized in fez config or mfdeploy or samba

Maybe it is the same problem with USB drivers conflict:

thank you for your timely response. I had to revert to the beginning of the steps. The one I thought was completely dead
I short pin 8 and 10 on port 3 then it responded and I did update.bat from the firmware directory then I went into fezconfig
and did firmware update and I had some problems with it recognizing the board after the firmware update then it came
around after rebooting it few times. and said it was up to date. so that fixed that one. the second one was showing up
as GHI Bootloader interface (COM 11) in the devices and printers Then I shorted the pins 8 and 10 on port three and it showed
up as bossa program port com 11. Then I did the update.bat from the firmware directory and then proceeded to fez config. I
ran into the same problem where it doesn’t recognize the update to the tinyclr right off the bat I had to disconnect and reconnect
a few times then when I did check for updates it show everything was up to date. So now I have both boards working. thanks for the link
it helped a lot. I learned that it needs to say G400 in the device manager for it to be properly installed. Not ghi bootloader interface.
why it loaded that driver I don’t know. My final question is is there a way to enumerate from a freshinstal revert back to factory defaults?

michael r


  another new question. under  advanced -> loader (tinybooter) update fez raptor doesn't show up anymore. How do

I get it back. I tried uninstalling ghi .net sdk and reinstalling it but it wont show up in fez config.
thank you for your reply

michael r

@ mdemulling - You’ll only have to short the pins and run Update.bat once. Once the bootloader is on there future firmware updates can be done through FEZ Config.

FEZ Raptor will only show up in FEZ Config under Advanced > Loader Update if you are using the pre-release SDKs: https://www.ghielectronics.com/support/netmf/sdk/40/ghi-electronics-netmf-sdk-2016-r1-pre-release-2

Ok thanks for the reply

Michae r