FEZ Raptor stuck in an infinite reboot loop

I was working on creating some display code for a T43 display, and must have put in an errant line of code that causes the board to crash and reboot as soon as the program starts executing. Now that the board is stuck in this infinite loop of rebooting, I can’t program the board with new firmware. I tried using the TinyBooter updater to start over, but the board never stays connected long enough to re flash. Any ideas?

1 Like

What about letting the Raptor only boot to the GHI-Loader?
Start FEZ-Config and select ‘Advanced’ - ‘Loader update’. That should fix it.

As glx says, put it into loader mode and then use FezConfig to erase the application.

I tried that. I tried using both the EDP and SP debug modules. Nothing seems to be working. In the connection tab, the board keeps going online and offline back and forth. Problem is, it never stay online long enough to program new firmware or update the loader. Any ideas?

1 Like

Thanks for the link. What ended up working was to put the device into boot loader mode, then go to the deploy tab and erase application memory. Nothing else worked. Thanks for the help everyone, glad to be back up and running.


May I suggest you first read the G400 SoM User Manual ?
4. Booting. Sequence And Control page 18

That is exactly what I suggested!! :whistle:

1 Like