Main Site Documentation

FEZ Raptor - SerCam throwing exceptions


#1

Hello,

Got my raptor a few days back and besides pushing a button and getting some leds on and off, totally newby with Gadgeteer en netmf.

I started playing around with the sercam and display today following the developers guide on the sercam product page. I keep getting slapped with error from the sercam;

Exception System.Exception - 0x00000000 (8)

#### Message: 
#### Gadgeteer.Modules.GHIElectronics.SerCam::ReadBytes [IP: 002f] ####
#### Gadgeteer.Modules.GHIElectronics.SerCam::ReadFrameBuffer [IP: 006b] ####
#### Gadgeteer.Modules.GHIElectronics.SerCam::UpdateStreaming [IP: 003a] ####

A first chance exception of type ‘System.Exception’ occurred in GTM.GHIElectronics.SerCam.dll

started reading the forum (https://www.ghielectronics.com/community/forum/topic?id=9506&page=1) and the net (http://stevenjohnston.co.uk/2013/04/10/net-gadgeteer-digital-camera-with-a-sercam/) but all sounds Chinese to me so trying my luck here :slight_smile:

  • I downloaded the sourcecode from codeplex and referenced it in my solution > no luck
  • I see quite some tutorials referencing the sercam mentioning events like StartDataCaptured but in my solution (referencing latest code from codeplex) no events to be found
  • The T43 display just sits there show so basic text data > Is that normal?
  • All seems correctly connected > at least to my humble experience up to now…

Maybe I am doing it completely wrong so please excuse me for the newbie questions :slight_smile:

Some help would be great!

Thanks, Xavier


#2

Read the getting started guide for the Spider located on the disk where you installed the GHI SDK. On my machine, it is located at C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Getting Started Guides. It is an example with the camera.


#3

The guide uses the Camera 1.1 module while I have the SerCam v1.0. Methods avaialble to the camera module in guide are not available in the sercam module…


#4

+1, I am experiencing this same issue. I made a post with my code here:

https://www.ghielectronics.com/community/forum/topic?id=14581


#5

@ xavierk - please see this post to help you diagnose your issue: https://www.ghielectronics.com/community/forum/topic?id=14581&page=1#msg147821


#6

And:

Disable Touch in your code, then disconnect wires in socket T if any.

Serial UART works incorrectly sometime if Touch is enable.

And, check all your cables if you tried above steps.


#7

OK. Thanks for the input. I’ll take a look at it later today and get back to you


#8

Disconnecting the T socket worked.
Strange though that you need to disconnect a socket on one module to get another module to work…
Are there any updates planned to fix the issue?
Thanks!


#9

Not strange ;D

Yes, it fixed


#10

@ Dat - not sure on the strangeness of things but seeing my newbie status I’ll take it as answer for now :wink:

Can I download the fix from codeplex? As such the sercam will function with the T socket connected? Kind of need it to fit in an app that of course needs the touch function on the display to work.


#11

This will require a new firmware to fix. You unfortunately have to wait for GHI to package and release it.