Main Site Documentation

FEZ Raptor Problem


#1

I have a new FEZ Raptor and I believe the USB driver/receiver portion of the unit is bad. I tried this board today for the first time. I hooked up a USB Client DP module, and a LED Strip Module. I was able to write and execute a program that cycled through the seven LEDs with no problem. Then I added a LED7C module, and could no longer attach to the USB port.
I have tried two different PCs, and two different USB cables, and when I plug in the USB cable there is not response, no connection in Device Manager. The Power LED on both the USB board and the Raptor both light up.
I am supplying power at 7 Volts, and the board (without the external LEDs) draws 83mA.
If I attach the LED Strip module, and press reset, first LED1 lights, then LED3 (yellow) lights after a few seconds. Pressing the reset switch drops the current drain to 33mA with it resuming to higher current after releasing the reset.
This indicates to me that the processor is alive.
The USB Client DP schematic does not appear to have any USB comms related components, nor does the Raptor backplane. There is no schematic I can find for the G400 board, so I do not know what to do next to further troubleshoot this problem. Since the device presence is not recognized, there does not appear any way this could be a firmware problem.
Any other ideas? I was quite surprised how easy it was to take the first baby steps, but now I am stopped.
In any case, Happy Thanksgiving!
Rocky


#2

Hi Rockybooth, welcome to the forum

Since you can’t see anything in device manager, seems like you might have a problem. Don’t suppose you hear any device connect/disconnect noises? Don’t suppose you have a different Client SP or DP module ? Also, can you confirm you have the DP module plugged into the D socket? Can you try a different Gadgeteer cable to the one that the DP module is using today?

Also, I would try booting into bootloader mode - follow the manual instructions on https://www.ghielectronics.com/docs/236/loader-tinybooter-update-g400 (step 2) and see if the device shows up in device manager then.


#3

Hi Brett:
Thanks for the quick response.
I have the DP module plugged into socket 8 which is marked DI, and which worked just fine at the start.
I tried a different cable, no love.
I tried a Netduino board, and works fine. When I unplug or plug in, it immediately caused device manager to refresh, showing its presence or absence. When I plug in the Raptor, no response.
I can try to order a new DP model if nothing else works, but it does not appear to have any active circuitry that impacts USB.
Then I tried your last suggestion, to boot to bootloader, and reload.
MAGIC! IT WORKS.

Thanks for your help. Shows that my diagnosis was wrong. Oh well.
Happy Thanksgiving!
;D


#4

We don’t celebrate thanksgiving in Australia, but I’m glad you now don’t have an excuse not to build that turkey monitoring device :smiley:

Since the bootloader + reload CLR trick worked, it implies something in your code was holding the CPU to ransom, for some reason. At least if you get in that situation again you can figure out how to get around it :slight_smile: