FEZ Raptor Not Responding

I brought my FEZ Raptor main board about 1 year ago, but used it only like 5 times. I update the firmware on it to after it I was able to deploy programs onto it. I haven’t Used it in about 4-5 months, and today I wrote a simple program to write a file to the SD card, but Visual Studio cannot communicate with it, and neither can the FEZ Config. I am really beginning to get scared, that I have to buy a new one.

It gives me the following error messages:

Thank You for your help in advance!

@ zacilaci - All the connections have been checked yes?

When you plug it in does the computer go bebooop?

@ zacilaci -
Not sure I can help but I occasionally have problems with USB not responding on my PC.
I am using Windows 8.1 Pro. I use a powered USB hub with a 2.5 Amp power supply.

You do not mention what modules you have connected to your Raptor when you try to connect to it.

I would suggest that you:

  1. Power down your PC.
  2. Disconnect the Raptor USB cable.
  3. Remove all modules except for the Display and the USB DP Module.
  4. Power on the PC and open the Device Manager.
  5. Plug your Raptor USB cable into a different USB port if possible.
    I would suggest that you use a powered Hub and not directly to the PC (if possible)
  6. If you do not see the Universal Serial Bus Devices G400 try using the device manager
    Action menu, Scan for hardware changes. See Cap.GIF
  7. If that does not work, power down your PC (leaving the Raptor connected)
  8. Restart the PC with the Raptor connected.

If you get connected use FEZ Configure to erase the existing application before doing anything else.

I would also suggest that you do a firmware update even if FEZ Configure thinks it is OK.

Good Luck!

I doubt that the Raptor is ruined. It is rugged - Unless you know otherwise.

when I see “worked a long time ago” “dusted it off” “doesn’t work now” I have two thoughts.

First, something simple is not behaving as expected. Usually I’d check cables, the USB module may have been dislodged or the USB cable itself is not a good one, so swap things around and try to validate connections all look correct

Second, the PC has changed, either it’s been rebuilt or reinstalled, or there’s a new PC in it’s place. That leads to driver differences so going back to fundamentals will help. Check when you first connect the device that you get a device recognised sound (may lead you to the USB cable finding above as well) but also make sure you boot into bootloader mode to then reapply the loader and firmware to make sure you’re at “fully clean” app. Follow the developers guide https://www.ghielectronics.com/docs/321/fez-raptor-developers-guide and the firmware update guide https://www.ghielectronics.com/docs/127/firmware-update


The Pc didn’t change at most I updated Visual Studio. Right now I am Re-Installing everything for the programming of the main board (Visual Studio, Gadgeteering packages etc.). When I connect it the pc it is in device manager as G400, when i go to bootloader it has the expected name, but when I try to upload a program onto it, it says: “Cannot attach debugger engine…” and when I want to delete the .hex file it says that: “device is not connected or not responding”. I hope that by reinstalling everything it will be good if not, I have no Idea what I can do.

good time to start taking screen shots of device manager.

Boot into bootloader mode, show us what DevMgr shows.
Boot into normal mode, show us what DevMgr shows.

One other thing you might want to do before reinstalling things (if not too late) is to uninstall the driver (and remove files).

@ Brett

Sorry, I am already installing Visual Studio, but before that I uninstalled G400 from device manager.

@ willgeorge
I tried your method, it sadly didn’t work. :frowning:

These are my screenshots of device manager: It’s good, identifies it, but when i try to communicate with the device it says that it can’t.

Yay!!! It is fixed! After reinstalling the whole program pack, and updating, or reinstalling the bootloader on the Raptor, it was able to communicate, the I only updated the firmware, and uploaded a black project, 1st it said that it cannot upload the file, continue? I said yes, then I re deployed it, succesfully accepted it, and it works now.

Thank You very much for all your help!!! :smiley: I’m really relieved!!! :smiley: Thank you very much for your support!!! :slight_smile:

1 Like

great news. We’re all here to help you be successful so don’t hesitate to come back and be part of the community !

1 Like