FEZ Raptor - Cannot update to use GHI Electronics NETMF SDK 2015 R1 Pre-Release 4

I believe it is related to Windows 10. ???

Visual Studio 2013 Pro
Windows 10 (Updated using Microsoft - MediaCreationToolx64.exe)
GHI Electronics NETMF SDK 2015 R1 Pre-Release 4

I have removed ALL .NET MICRO and GHI SDK software and re-installed it.

I cannot update the Loader…
I receive COM Port 3 - (Bossa Program Port)

Please reply! - What is the BAUD rate used by the Bossa Program Port? I am using 9600.
Is this correct?

See FEZConfig.GIF
FEZ Config (Run as Administrator)

Device USB G400_G400

Loader (TinyBooter) version information: on this computer. on this device.

The Loader (TinyBooter) not up to date. <<<

Firmware (TinyCLR) version information: on this computer. on this device.

The Firmware (TinyCLR) is not up to date. <<<
Please wait for the device to reboot… Done.

I did the following:

See G400.gif
Right click on the Update program. And choose “Run as administrator”
C:\Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Firmwares\G400
Using: Update Loader.bat as Administrator

See FEZHydra.gif
Shows files in:
C:\Program Files (x86)\GHI Electronics\NETMF v4.3 SDK\Firmwares\FEZ Hydra

I receive the following:
See Error.gif

My registry information:
See Registry.gif and Registry-1.gif
I ‘think’ this is wrong. But… What do I know…?

Value name: instdir
Value data: C:\Program Files(x86)\Atmel\sam-ba_2.12

I have no directory in my Windows 10 - C:\Program Files(x86)\Atmel\sam-ba_2.12

GHI Electronics FEZ Hydra Loader Update Log-32641-52.09.txt

Log contents:
-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA CDC 2.10 on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : com3
-I- argv 1 : at91sam9rl64-ek
-I- argv 2 : Loader.tcl
-I- Connection : com3 (target(comType) = 3)
-I- Board : at91sam9rl64-ek
-I- Traces Level : 4
-I- target(handle) : file271b1d0
Read device Chip ID at 0xfffff240 — get 0x819a05a1
Read device Chip ID at 0xffffee40 — get 0x00000000

Any ideas?


@ willgeorge - We did test updating the FEZ Raptor and FEZ Hydra on Windows 10 and it ran fine. Don’t run the script as administrator, that isn’t needed anymore with this SDK. Does the sam-ba program exist under C:\Program Files(x86)\Atmel\sam-ba_2.12 and does it run?

@ John -

As stated in my post…
I have no directory in my Windows 10 - C:\Program Files(x86)\Atmel\sam-ba_2.12

I remember that Windows 8.1 Pro had it.

I assume your SDK installs it?

@ willgeorge - Ah, sorry. You can try to reinstall it from https://www.ghielectronics.com/downloads/NETMF/SDK/sam-ba.2.12.exe

@ John -
Downloaded (Your link) sam-ba.2.12.exe and ran it.

It never finishes. Task Manager shows it but it just hangs there.

@ andre.m -

are you sure there is no window anywhere where you have to click a button?

To the best of my knowledge there is no window/button etc.

Task manager shows it but appears not to be running…

See gif file.

I did a Dump: Probably make more sense to you than me!

Dump Summary

Dump File: sam-ba.2.12.DMP : C:\Users\willgeorge\Desktop\sam-ba.2.12.DMP
Last Write Time: 8/3/2015 5:18:19 PM
Process Name: sam-ba.2.12.exe : C:\Users\willgeorge\Desktop\sam-ba.2.12.exe
Process Architecture: x86 (64-bit dump)
Exception Code: not found
Exception Information:
Heap Information: Present

System Information

OS Version: 10.0.10240
CLR Version(s):


Module Name Module Path Module Version

sam-ba.2.12.exe C:\Users\willgeorge\Desktop\sam-ba.2.12.exe
ntdll.dll C:\Windows\System32\ntdll.dll 10.0.10240.16392
wow64.dll C:\Windows\System32\wow64.dll 10.0.10240.16384
wow64win.dll C:\Windows\System32\wow64win.dll 10.0.10240.16384
wow64cpu.dll C:\Windows\System32\wow64cpu.dll 10.0.10240.16384
sam-ba.2.12.exe C:\Users\willgeorge\Desktop\sam-ba.2.12.exe
ntdll.dll C:\Windows\SysWOW64\ntdll.dll 10.0.10240.16392
kernel32.dll C:\Windows\SysWOW64\kernel32.dll 10.0.10240.16384
KERNELBASE.dll C:\Windows\SysWOW64\KERNELBASE.dll 10.0.10240.16384
apphelp.dll C:\Windows\SysWOW64\apphelp.dll 10.0.10240.16384
AcLayers.dll C:\Windows\AppPatch\AcLayers.dll 10.0.10240.16384
msvcrt.dll C:\Windows\SysWOW64\msvcrt.dll 7.0.10240.16384
user32.dll C:\Windows\SysWOW64\user32.dll 10.0.10240.16384
gdi32.dll C:\Windows\SysWOW64\gdi32.dll 10.0.10240.16390
shell32.dll C:\Windows\SysWOW64\shell32.dll 10.0.10240.16405
windows.storage.dll C:\Windows\SysWOW64\windows.storage.dll 10.0.10240.16405
combase.dll C:\Windows\SysWOW64\combase.dll 10.0.10240.16384
rpcrt4.dll C:\Windows\SysWOW64\rpcrt4.dll 10.0.10240.16384
sspicli.dll C:\Windows\SysWOW64\sspicli.dll 10.0.10240.16384
CRYPTBASE.dll C:\Windows\SysWOW64\CRYPTBASE.dll 10.0.10240.16384
bcryptPrimitives.dll C:\Windows\SysWOW64\bcryptPrimitives.dll 10.0.10240.16384
sechost.dll C:\Windows\SysWOW64\sechost.dll 10.0.10240.16384
advapi32.dll C:\Windows\SysWOW64\advapi32.dll 10.0.10240.16384
shlwapi.dll C:\Windows\SysWOW64\shlwapi.dll 10.0.10240.16384
kernel.appcore.dll C:\Windows\SysWOW64\kernel.appcore.dll 10.0.10240.16384
SHCore.dll C:\Windows\SysWOW64\SHCore.dll 10.0.10240.16384
powrprof.dll C:\Windows\SysWOW64\powrprof.dll 10.0.10240.16384
profapi.dll C:\Windows\SysWOW64\profapi.dll 10.0.10240.16384
oleaut32.dll C:\Windows\SysWOW64\oleaut32.dll 10.0.10240.16384
setupapi.dll C:\Windows\SysWOW64\setupapi.dll 10.0.10240.16384
cfgmgr32.dll C:\Windows\SysWOW64\cfgmgr32.dll 10.0.10240.16384
mpr.dll C:\Windows\SysWOW64\mpr.dll 10.0.10240.16384
sfc.dll C:\Windows\SysWOW64\sfc.dll 10.0.10240.16384
winspool.drv C:\Windows\SysWOW64\winspool.drv 10.0.10240.16384
bcrypt.dll C:\Windows\SysWOW64\bcrypt.dll 10.0.10240.16384
sfc_os.dll C:\Windows\SysWOW64\sfc_os.dll 10.0.10240.16384
SortWindows61.dll C:\Windows\SysWOW64\SortWindows61.dll 10.0.10240.16384
imm32.dll C:\Windows\SysWOW64\imm32.dll 10.0.10240.16384
msctf.dll C:\Windows\SysWOW64\msctf.dll 10.0.10240.16384
ole32.dll C:\Windows\SysWOW64\ole32.dll 10.0.10240.16384
comctl32.dll C:\Windows\WinSxS\x86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.10240.16384_none_3bccb1ff6bcd1849\comctl32.dll 6.10.10240.16384
version.dll C:\Windows\SysWOW64\version.dll 10.0.10240.16384
uxtheme.dll C:\Windows\SysWOW64\uxtheme.dll 10.0.10240.16397
shfolder.dll C:\Windows\SysWOW64\shfolder.dll 10.0.10240.16384
clbcatq.dll C:\Windows\SysWOW64\clbcatq.dll 2001.12.10941.16384
propsys.dll C:\Windows\SysWOW64\propsys.dll 7.0.10240.16384
riched20.dll C:\Windows\SysWOW64\riched20.dll
usp10.dll C:\Windows\SysWOW64\usp10.dll 10.0.10240.16384
msls31.dll C:\Windows\SysWOW64\msls31.dll 3.10.349.0
dwmapi.dll C:\Windows\SysWOW64\dwmapi.dll 10.0.10240.16392
InstallOptions.dll C:\Users\willgeorge\AppData\Local\Temp\nsdA2B.tmp\InstallOptions.dll
comdlg32.dll C:\Windows\SysWOW64\comdlg32.dll 10.0.10240.16405
tiptsf.dll C:\Program Files (x86)\Common Files\microsoft shared\Ink\tiptsf.dll 10.0.10240.16384

@ willgeorge - I would again uninstall everything related to the SDK, including sam-ba and the ST DFU tool if they exist. To uninstall sam-ba, you have to run C:\Program Files (x86)\Atmel\sam-ba_2.12\Uninstall.exe. Restart your computer, then try to just install sam-ba from the link I provided. Then install our SDK and uncheck FEZ Hydra/G400 Loader Updater under Advanced.

@ John -

Thanks for the reply.

My problem is that I never get sam-ba installed properly.

I never get the folder C:\Program Files (x86)\Atmel\sam-ba_2.12 on my Windows 10

@ willgeorge - I know, that’s why I wanted to start fresh by uninstalling everything and trying to just install sam-ba after a reboot.

@ John -
I have uninstalled everything, rebooted, reinstall everything about 5 times!
I never got the C:\Program Files (x86)\Atmel folder.


  1. I uninstalled everything, rebooted, reinstall everything again
  2. I went to AMTEL and downloaded sam-ba_2.15 and ran it on my Windows 10.
    Guess what… It installed in about a minute. sam-ba 2.12 flat will not install on my windows 10.
  3. I edited the batch file.


CD “%~DP0”

FOR /F “tokens=2*” %%A IN (‘REG QUERY “HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Atmel\sam-ba\2.15” /v “instdir”’) DO (
SET Samba=%%B\sam-ba.exe

IF NOT EXIST “%Samba%” (
FOR /F “tokens=2*” %%A IN (‘REG QUERY “HKEY_LOCAL_MACHINE\SOFTWARE\Atmel\sam-ba\2.15” /v “instdir”’) DO (
SET Samba=%%B\sam-ba.exe

IF NOT EXIST "%Samba%" (
	ECHO The "G400/FEZ Hydra Loader Updater" cannot be found.


ECHO The update will take a few minutes. Once the update has completed successfully,
ECHO “Loader Update Complete” will be displayed. The "G400/FEZ Hydra Loader Updater"
ECHO must be installed for this script to function.

ECHO Please enter the number part of the COM port of the G400.
ECHO For example: enter only the number 10 for COM10.

SET /P Port=COM Port Number:

ECHO Updating…


“%Samba%” \USBserial\COM%Port% at91sam9g15-ek Loader.tcl > “%LogName%”

TYPE “%LogName%”

ECHO You can find the above log at %LogName%.


SET LogName=%TEMP%\GHI Electronics G400 Loader Update Log-%RANDOM%-%TIME:~6,5%.txt

  1. Saved the batch file to a new name and now everything is OK… At least on my Windows 10.

See GIF file

If it matters, my Windows 10 was updated from Windows 8.1 Pro using the Microsoft MediaCreationToolx64.exe

I’m up and running… I think!


Same here but I upgraded from Windows 7 Professional x64

Information only:

This is a update about my problems installing
FEZ Raptor - Cannot update to use GHI Electronics NETMF SDK 2015 R1 Pre-Release 4

Along with issue installing sam-ba (Does not install) there is also a issue with the GHI Bootloader interface (Installs but I receive - This device cannot start. (Code 10))

It appears that it is related ONLY to the Windows 10 update on my most used PC.

I took all of the files (from GHI .NET Micro Framework Download & Install Steps) and copied the files to a laptop that was just updated to Windows 10.

Using the same files from the PC install that fails:
EVERYTHING installed without a hitch on the first try.

My way to say that my issues have NOTHING to do with GHI supplied software.

Posted this so it is clear that I have no gripes with GHI!

As with Windows 8 it appears that with Windows 10 I still have a Spider I cannot update.

Problem is I have no older PC I can use that can use the GHI Bootloader Interface.

I decided to do a clean install of Windows 10 on this machine and now it works.

@ Sprigo and willgeorge - There is a new version of the drivers in the pre-release SDKs because of an issue we found on Windows 10. When you do an upgrade, it is possible that Windows was caching the old drivers internally and not using the new fixed version.

@ John -

Just to let you know. I have been working on this all night and I finally got the GHI Bootloader Interface to work on my desktop PC.
I tried each and every USB Port with a reboot on each change. All ports gave the same error (Cannot start). On a whim, I disconnected my powered USB Hub which I use all the time. With the powered Hub NOT used the GHI Bootloader Interface started and I was able to load Tiny Booter on my spider. I tried three different brand powered hubs and they all made the interface fail?

See attached GIFs:

As to my laptop (with Windows 10) all USB ports (only four) fail powered hub or not. I have no idea why.

Thanks for your time!

@ willgeorge - Does your hub work for other devices? I have a hub that fails to work at all in Windows 10.