FEZ Raptor and NETMF SDK 2015 R1 Pre-Release 4 Networking issue


Has anyone else experienced lockups since upgrading to NETMF SDK 2015 R1 Pre-Release 4 on the FEZ Raptor?

I seem to be getting the lockup either directly after obtaining an IP address OR during the creation of an AMQP.Net Lite session ( I haven’t had time to decipher which yet). The code I have has worked on all of the NETMF SDK 2015 R1 Pre-Releases and after rolling back to NETMF SDK 2015 R1 Pre-Release 3 works again!

I am willing to send my code to GHI privately if they want to check but unfortunately I am in the process of testing the ability to remote update firmware and haven’t got the time to diagnose the issue for a few weeks!

@ networkfusion - Does the board completely lock up or does just networking become unresponsive?

I believe it was the board. The display and buttons became unresponsive and the debug output didn’t continue to stream…

@ networkfusion - If you get time, could you add a blinking LED to it in a separate thread and see if that continues? If possible, if you can, a small example that reproduces the issue for us to take a look at helps a lot.

@ John I installed the G400 bootloader preview and received the same issue as before when running Pre Release 3. I then updated to 2015 R1 and updated the project references and the issue has disappeared! Perhaps the original issue was to do with a reference / bootloader / firmware being out of sync somewhere when I originally tried it… Sure wish that updating the G400 SSL seed from within FezConfig would be resolved though!