Main Site Documentation

FEZ Panda with WIZ811MJ on Arduino Shield - HELP


#1

Due to the fact there aren’t any available networking modules I thought I’d try to build one from supported hardware. Here’s what I have done and it does NOT work so I’m looking for any guidance.
Purchased items:
FEZ Panda - Firmware 1.7
WIZnet811MJ - found here: http://www.sparkfun.com/products/9473
(I chose this because it has the WIZ5100 chipset)
Ethernet Shield - found here: http://www.ladyada.net/make/eshield/index.html
(I chose this since it’s meant for the 811MJ/WIZ5100 chips and it’s supported on arduino)

I followed the directions for building the shield. I attached the built shield with the 811MJ stacked on it and used the basic website code from the FEZ Ethernet Shield PDF. I’ve also tried others with no avail. So I’m wondering if I’m the only person who has tried this and or is there a way to make it work. I have also tried the “bent reset pin” option with no change. I know that the shield electronically is working since the RJ45 LED’s flicker when a network cable is plugged in.
When I deploy the web code the onboard LED becomes dim but stays lit.
Any input would be greatly appreciated.
Thanks.


#2

Can you be more specific? ‘does NOT work’ is hard to troubleshoot ???


#3

When I mean it doesn’t work I’m referring to the sample web server code deployed to the Fez. There are no errors in code/deployment. I do not get a ping nor access to the specified IP/URL.


#4

Have you seen this?
http://www.ghielectronics.com/catalog/product/261


#5

I have and will be purchasing it but I have a demo of our product before this is available. We needed to test web interface commands.


#6

I have had a lot of success with this one as well. http://www.seeedstudio.com/depot/wiznet-ethernet-shield-w5100-p-518.html?cPath=102&zenid=d5f45e69919d524695d761fed7b2266d
You need to remember to move the jumpers on this one.


#7

Have you seen this? http://www.ghielectronics.com/downloads/FEZ/Shield/Broch_EthernatShield.pdf
Maybe it will help?


#8

You can connect the Wiznet module directly to Panda using wires to test if it works. After that you can try to use it with the shield. I did the same with similar WIZ810MJ module:

http://www.tinyclr.com/forum/2/2733/

Your module however has a different pinout than mine (see below picture). You want to use pins:

[ulist]
[li]GND[/li]
[li]3V3D[/li]
[li]SCLK[/li]
[li]MISO[/li]
[li]MOSI[/li]
[li]SCS[/li]
[li]RESET[/li]
[/ulist]

and connect them to your Panda board pins as follows

[ulist]
[li]GND[/li]
[li]3V3[/li]
[li]Pin 13[/li]
[li]Pin 12[/li]
[li]Pin 11[/li]
[li]Pin 10[/li]
[li]Pin 9[/li]
[/ulist]

An try to use your Web server.


#9

Thank you for the reply. I made the changes and that worked.

Greatly appreciated. I’m glad this works!


#10

Architect, watch out as Gralin is about to be the new super help bot :smiley:


#11

By all means! ;D


#12

A loooong way to go :wink: