Main Site Documentation

FEZ Panda - Loader erase doesn't work for me


#1

Hello - I am another one of those MAC users, and want to use Panda with a development environment on my MAC - Eclipse, etc. I have followed the directions in the section 11.4 of the Beginners Guide to Porting NETMF. I am able to successfully download the Do_NOT_use_will_erase_firmware.GHI file over a serial connection to the board. However, when it resets and runs the output looks the same as running a regular NETMF firmware install and even reports as such when I run MFDeploy. The version reported by the loader is 1.07, and I have installed the latest tools, VS 2010 and all the 4.1 versions of NETMF, SDK, etc. and have successfully run an example program using Parallels. I have also been able to properly execute the E command in the loader, verify FW is erased and reinstall.

Is there another trick to getting the code to erase the LPC2387 completely so I can connect via JTAG and use FlashMagic?


#2

This is disabled for now.

So you are not interested in using NETMF and instead you want to program the processor using C with GCC compiler?

You also have a serial port connected to UART0?


#3

That is correct. I have an Eclipse, GNU toolchain and openOCD-JTAG setup on my MAC that I would like to use. I do have a serial port connected to UART0.


#4

I purchased the FEZ Panda thinking that I would be able to use it in my project as a plain LPC2387. I didn’t realize that the micro would be locked out from JTAG.

When will GHI enable the option to completely erase flash and open the micro up to JTAG and NXP ISP?


#5

Very soon but you can’t wait, please send the board and we will unlock/erase for you. Or buy a new one and request that it is shipped with blank processor


#6

I will wait - Thank you for your support.


#7

Just curious if there’s been any update on erasing/JTAG/programming with Pandas yet?
I read http://tinyclr.com/forum/2/875/ before ordering my Panda, but didn’t read this (or a couple of other posts) soon enough I guess.

I’m very interested in using the board for doing my own NETMF porting (maybe doing some work w/ FEZOpen (which doesn’t appear to have been touched in months??)).

Thanks! ;D


#8

You can order one and request it to be blank. Someone did that and got lua running on fez already

Fezopen is open and is a community collaboration. We look forward to work on it more when we see interest and contributions from the community


#9

I must remember you guys that you didnt change the web page and it is saying that it includes JTAG port which is not true at the moment. You should at least change that web page.


#10

But the JTAG port is physically available on the FEZ Panda board. You have to solder some pins on it and you have a JTAG connector. It think it is locked inside the chip.


#11

Yes, the physical JTAG interface is present on board but its useless if it is locked.

Thats why I said to include something like (Cooming soon) or directly erase it from the page. Because there are lot of people who buy the panda to simple see what can be done in C# thinking to use lately as a dev board which cannot be done.

In my case if I have to return it to GHI to unlock it, it cost more than the board so its not an option.

I’m not complaining about this as I can wait for GHI to realese the erase code when they think is realiable to do that.
In the meantime I think is better to let the potencial new user know that this feature is no ready by now and if they need to use it as a dev board they should ask for it when they purchase them. This is not listed anywhere but the forum.

This is just my suggestion and I will wait till they have the erase code released.


#12

You do not have to wait. Send us your board and we will unlock it for you or buy new one and put a note indicating that you need a blank board.

But I agree we should get to this soon so make life easier for everyone.


#13

Any news here?

I bought 6 Panda II boards to use as blank LPC2387 devel boards because on your website you still say “JTAG exposed” and on your porting guide (http://www.tinyclr.com/downloads/Beginners%20Guide%20to%20Porting%20NETMF.pdf) you even describe how to remove the bootloader and get access to JTAG. But I’m more than just disappointed now that I realized it doesn’t work as promised!

Buying a product and sending it then (on my own costs) to the manufacturer so it meets the promises made to me is not the way this should work. Why is there still no way to remove the firmware and when can I expect a solution to this.

Thanks in advance,
Plum


#14

Plum, I don’t think anywhere there’s mention of these boards being “blank developer boards”, but if you’re concerned about that then I’d suggest you contact GHI directly via their website to discuss what to do here. Asking questions here doesn’t add anything, you’re better off just going directly to the people who can assist resolving this.


#15

I have forwarded the concerns to our team and they are looking into options.


#16

http://www.ghielectronics.com/contact/ says that FEZ devices are supported in this forum. Thanks for your worthy comment, but an “exposed JTAG” interface for me means that you should be able to use it. And this is what is mentioned at GHI and here (http://www.tinyclr.com/compare/). Also the Link of the eBook I posted below from this site shows the possibility to delete the bootloader and use JTAG then.

So really your answer doesn’t help me very much, because “Gus” told they are working on a solution and I just want to know, when the boards will meet the promises made.

EDIT: Thanks Gus for your answer…

Again best regards Plum


#17

Patience is all we are asking for. We are going out of our way trying to get as many users benefiting from FEZ as possible :slight_smile:


#18

Here it is http://www.tinyclr.com/forum/17/2734/